I'm trying to get the OS Window to fit the VirtualBox container, but I've tried every option under the View menu to no avail. This is ridiculous. Please help!

VirtualBox Window Error

  • 1
    That's so ridiculous it's almost awesome. Can you log in to Windows under those conditions? Something seems wrong with the display driver. Does full screen work? – Tanner Faulkner Oct 18 '12 at 18:55
  • 3
    Have you installed the virtualbox additions in windows? Devices -> Install guest additions If you manage to install it that is. – dset0x Oct 18 '12 at 19:14
  • I did install guest additions previously, although the option is still there under the Devices menu. When clicking it again, nothing happens - I'm guessing because it's already installed. – manafire Oct 18 '12 at 20:43
  • Ha, logging in isn't possible. Full screen mode looks the same. – manafire Oct 18 '12 at 20:44
  • This might have to have something to do with dual displays. Some of my other windows have collapsed like this before, after plugging in my external monitor. – manafire Oct 18 '12 at 20:47
  1. Try booting up in safe mode. If you can login and use the machine, Uninstall/Reinstall graphics drivers. Also uninstall and reinstall the Guest Additions. Reboot and see if this fixes the issue.

  2. Make sure VirtualBox is up to date.

  3. If the issue persists, go to Settings->Display->Video and try Video Memory = 128mb or Video Memory = 256mb, and verify both Enable 3D Acceleration & Enable 2D Video Acceleration are checked (if it still doesn't work you can try unchecking these and rebooting to see if it may let you view the screen normally).

  4. As a final last ditch effort, you may want to try booting up normally, and RDP'ing into your virtual machine (this is assuming remote desktop is switched on). Then you might be able to view the screen normally and check display settings in your user account. I noticed you're on the os x environment; Cord is a good RDP program to remotely screenshare with Windows 7. Make sure you have the network adapter set as bridged, and get the ip of the Virtual Machine on your router, it will be different from the Host Machine. If RDP is off, you might be able to enable it using this tutorial (it assumes remote registry is enabled).

  5. As a last resort, you may try enabling remote desktop by going to Settings->Display->Remote Display and enable the server there, use port 7777. Use Cord, and type localhost:7777 to connect when it is booted up. Make sure you have the network adapter set as Bridged. My guess is this last method probably won't work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.