On my Windows 8 desktop I keep getting error 0x80073cf9 when I try to install or update an app from the windows store.

In the installings apps pane it just says "This app wasn't installed -- view details" and when I select that it says "Something happened and this app couldn't be installed. Please try again. Error code: 0x80073cf9"

I am using the built-in windows firewall and antivirus. And my laptop is able to install updates when it is on the same network.

This is what winstore.log shows when I try to update the maps app:

2012-10-18 15:31:47.328, _Info_                WS   [00015160:00011628] ***********************************************************************
2012-10-18 15:31:47.328, _Info_                WS   [00015160:00011628] Process name: C:\Windows\system32\taskhost.exe
2012-10-18 15:31:47.328, _Info_                WS   [00015160:00011628] User name: Desktop\User
2012-10-18 15:31:47.328, _Info_                WS   [00015160:00011628] Computer name: desktop
2012-10-18 15:31:47.328, _Info_                WS   [00015160:00011628] Windows build: 9200.16424.amd64fre.win8_gdr.120926-1855
2012-10-18 15:31:47.328, _Info_                WS   [00015160:00011628] Client version: 615
2012-10-18 15:31:47.328, _Info_                WS   [00015160:00011428] CWSTileUpdateHandler::Worker: Broker is handling badge updates.
2012-10-18 15:31:47.554, _Info_                WS   [00002572:00008200] CProgressDispatcher::OnProgress: AppId = 97a2179c-38be-45a3-933e-0d2dbf14a142, PFN = Microsoft.BingMaps_8wekyb3d8bbwe, InstallPhase = 1, PhasePercent = 0, TotalPercent = 0
2012-10-18 15:31:47.558, _Warning_             WS   [00002572:00008200] CDownloadProgress::IDownloadCompletedCallback::Invoke: Download complete result 0x80073cf9 for Microsoft.BingMaps_8wekyb3d8bbwe
2012-10-18 15:31:47.559, _Error_               WS   [00002572:00008200] CActionItem::_DoDownload: Download failed for 97a2179c-38be-45a3-933e-0d2dbf14a142, hr=0x80073cf9
2012-10-18 15:31:47.560, _Info_                WS   [00002572:00008200] CActionItem::_DoDownload: Notifying progress handlers of download failure for 97a2179c-38be-45a3-933e-0d2dbf14a142, hr=0x80073cf9
2012-10-18 15:31:47.560, _Error_               WS   [00002572:00008200] CProgressDispatcher::OnError: PFN = Microsoft.BingMaps_8wekyb3d8bbwe, InstallPhase = 1, hrError = 0x80073cf9

Not sure how it could have happened, but this seems to be a possible solution:

The problem is that the folder AUInstallAgent is missing from the Windows folder. I had this problem, recreated the folder and low and behold all is working fine. Now what I want to know is why the folder disappeared in the first place, because I didn't delete it, and looking around the web I'm not alone....

  • I tried this. It stops the install from crashing, but the install just hangs at "Pending" now. – cmorse Oct 19 '12 at 15:29
  • Ok, after rebooting it works just fine. Go figure! – cmorse Oct 19 '12 at 16:32

Microsoft has a support article, Troubleshoot problems with an app, that offers a download of the Windows Store App Troubleshooter which will try to detect and correct any problems with the Store.

This solved it for me.

(I have tried all the mentioned solutions and none of them worked for me. I also tried to run WSReset, uninstall and re-install, nothing wanted to work. I was about to format and reload my PC, when I found one last suggestion to try and it sorted out the problem!)

  • 1
    Welcome to Super User. To provide some context, I added a link to a Microsoft support article which, however, has a slightly different link to that Store App Troubleshooter. I'm not on Windows, no idea if it's actually the same download. – Arjan Sep 16 '14 at 19:59
  • Hi Arjan. Thank you for adding the Microsoft Support Article. Yes, that does indeed still link to the correct download. – WJK Sep 18 '14 at 5:41

First I do not want to take credit for this!

The hint was given by "Alex from the ’90s", as solution for a download problem of Asphalt 9.

ERROR 0x80073CF9 nagged me for over a year now. All store repair procedures failed, ending with the reinstall all suggestion.

Now here the solution. Take care modifying registry values!


It's value has to be set to ZERO.

Apparently the Microsoft Store wants to make use of partial file encryption, possibly for license protection reasons.

If you have that value set to 1 accidently (maybe with a modding tool), that procedure simply fails. 0x80073CF9 is maybe not the best code to indicate that.

  • I've tidied up your post to bring it more inline with the standards we expect here. Please see How to Answer and take our tour for more information. If you feel I have gone too far away from your meaning please edit as you see fit. – Burgi Feb 4 '20 at 16:02
  • ...all perfectly fine Burgi :-) actually.. thanks for doin that for me, i am new here and will shure check that howto out :-) I just hope, that info will be helpful for someone :-) high fives... – CyTraveler Feb 5 '20 at 14:29

I tried almost everything to no avail. Then I added a new user (with administration rights) from with in the control panel.

If you go to Users Accounts in the Control Panel, click manage accounts then find the add accounts link. After you have added the account with a different name, hit Ctrl Alt Del, select SIGN OUT, then sign in as the new user, all the app stuff now works, try it out.

All your programs are there, if not on the desktop, you can add a shortcut link on the desktop. The next step is to delete the old and worthless user. Done. You can rename the new user from the control panel.


Try creating the folder AppReadiness in the %windir% folder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.