13

I have installed an external monitor (Dell ST2220L, 21.5 inch) on my laptop (Sony Vaio). I am using a DVI-D cable for connection. Since the laptop does not have a DVI-D port, I have connected a DVI-D to HDMI connector on the laptop end and inserted the cable in HDMI port of the laptop..

I have switched off the laptop display and adjusted the screen resolution on the Dell external monitor to 1920 x 1080 and adjusted colors for the Windows 7 and brightness and contrast from the monitor.

The problem is the monitor turns of blank intermittently for 1-2 seconds and turns on again at random interval. What could be the reason for this and how to get rid of this problem?

12 Answers 12

2

This seems to be a connectivity issue. Try and wiggle the adapter, and all the connections while powered, and see if you can make the problem appear. Don't forget to test the connection at the display too.

1
  • 5
    I tried wiggling all the connectors but could not make the problem appear. Oct 19 '12 at 15:18
9

I believe it's most likely a bug in the generic Windows display driver. It's possible you can solve this with a driver from Dell for your display.

I've struggled with exactly that same behavior in one of my monitors, where it randomly goes dark for a couple seconds, then comes back on. The interval between could hours or it could seconds (almost constant flickering.)

In my case, it's two Dell 2405FPW panels side-by-side on my desktop and the problem only presented on my left monitor. Web searches at the time confirmed this a common problem, but seen only on the then-new Windows release I was running and could be traced to Dell having dropped support and not releasing a driver. The random behavior was because I was using the default driver. It drove me nuts for years (but I was too cheap to buy new panels that were supported.) The problem finally (fingers crossed) appears to have gone away a couple months ago with an Nvidia update for my graphics card.

In your case, I don't see others reporting the same behavior with your model and it looks like Dell still supports your monitor. But the behavior you're seeing is exactly what I saw from the default driver. This is why I suspect it may be as simple as downloading the proper driver from Dell.

Good luck. I hope this helps.

2

I believe it is an HDMI issue as I am having the same problem with a new Vizio 50-inch LED TV. When using HDMI to watch cable tv or Blu-ray discs I get intermittent "no signal" displays where both video and audio disappear for a couple of seconds and then come back. Using component connections I don't have that problem. I don't like using component since the picture quality is not as good, but I can't find a better solution for the time being.

1

There are many reasons why a monitor keeps turning off, resulting in a blank display. The best way to resolve this problem is through process of elimination; as such, I will go through the list of things you can do to help determine why the monitor keeps going black or turning off sporadically.

Simply put: both DVI and HDMI are digital signals; if the signal is too weak, the monitor won't sync to the computer, resulting in a blank screen. If the cable run is too long, or of the signal has been split (using a non-powered DVI or HDMI splitter), this can cause the monitor to go black because the signal isn't strong enough.

Based on my experience, some HDMI cables will simply stop syncing properly after a while, even though they worked fine previously, and even though the same cable works fine on another device. Sometimes, HDMI cables won't work properly if there has been a recent hardware configuration change. For example, you may have purchased a stereo receiver and ran the cable through the receiver instead of directly through the monitor. In this case, you can bypass the splitter or receiver and see if that makes any difference.

https://www.infopackets.com/news/9589/how-fix-monitor-keeps-going-black-turning

1

I had this exact same problem with a Surface Pro 4, Monoprice monitor MP-28UHDSS. Seemed to start happening after the Windows 2018 May Update. I tried various suggestions, none worked for me until I went to Advanced Display Settings, Display Adapter Properties, and found that the screen refresh rate was set at 59Hz. No idea where that came from. I changed to 30Hz, and problem is definitely gone.

1

For some strange reason whenever my phone is near the usb-c adapter thing the external monitor turns off. At first my external monitor wouldn't go on because my phone was near the adapter when i moved my phone away it turned on and there was no turning black intermittently ever again.

1

Current fluctuation at mains supply can cause HDMI monitor to momentarily black-out, such as a fridge compressor switching on and off.

0

I had the same problem with a Dell U2515H screen that turned blank for a second or two now and then. Had the newest drivers installed for both the graphics card and the monitor.

Was able to solve it by disable "DP 1.2" (had enable it previously to allow daisy chain of two monitors).

0

This is going to sound crazy, but I have solved this and other external display issues in Windows 10 by simply logging in as an administrator on the computer. Then I can log out and back in as my regular user, and the issue is gone!

I usually run Windows as non-admin, and it seems Windows wants to "do things" with regards to the monitor that it needs administrator rights to do. Weird that I get no notification whatsoever about this.

(Edit 1: It seems like I have to always remain logged in as an administrator in the background, and switch to my regular user, for the issue not to appear again.)

(Edit 2: Like I have read on other places, these kinds of fixes usually only work for a short while, so the problem was NOT solved.)

(Edit 3: The problem was solved when I switched monitor. It seems my DELL UltraSharp 24 something was faulty or incompatible somehow. A newer DELL UltraSharp 27 and a Samsung 27 works perfectly now.)

0

So here's something interesting to add to this older discussion...I currently use a pair of monitors (mismatched, an Acer V276HL, connected via DVI-D, and a ViewSonic VX2753MH-LED.

The ViewSonic died a couple of years ago. The input connectors and power connector failed one by one, and I eventually ended up buying a new driver board from ViewSonic and replacing it this past November.

As of last week, the monitor began shutting off, and coming back on. I don't think it was a signal loss: the display would completely power off and the ViewSonic logo would show after it restarted.

During this time it was connected via HDMI, to my PC.

I wanted to test out whether or not it was the signal, etc., so I switched it to the other DVI port, with a DVI-I to VGA converter, and ran that into the VGA connection on the back of the monitor (it has two HDMI ports as well).

I assumed it would also turn off and on, my suspicion was that the replacement board was rapidly going bad. But now that I have it connected to a standard 15-pin VGA input, it's been rock solid for the last 48 hours.

So, you might try a different cable method even if the quality isn't exactly what you'd prefer, and see if it keeps doing it.

0

spurious voltages on the hdmi cable and induced voltages can cause something like a capacitance to build and cause issues...

Turn off PC, unplug monitor hdmi at both monitor and pc, UNPLUG THE PC. Let the power supply drain (wait a few minutes). Unplug the monitor power.

Now, connect monitor and pc hdmi. Plug in monitor and plug in pc.. if all goes well the spurious voltage that was there will disappear.

If it comes back - check you are not running power cables un-shielded next to your monitor cables or other cables going to or from pc. Just give them some room... cheap cables are highly susceptible to cross em interference.

Try using another, better quality preferable, hdmi cable also. Make sure there's no dust on the pins or components. If you have access into the PC - carefully follow manufacturer recommended cleaning (gently air dusting to remove dirt building up on main boards and graphics cards or other components - especially in the power supply and graphics connection points. DO THIS WHILE IT IS UNPLUGGED!!!! If you don't know what you're doing - call a friend that does.

If all else fails - check your power supply voltages and make sure they are all within normal tolerances. Some monitors are easily damaged by unbalanced grounds on the hdmi and main power. There may be dangerous reverse potential on the neutral or ground lines as a result of a failed diode or something.. can't tell you all the many ways I have seen electronics lose their magic smoke but there are many possible physical component issues possible.

By far the most likely is that the cable is bad or there is some random spurious voltage that has been induced on the line somewhere. HDMI has power on it and if there is a connection that is not solid or any standing waives from a kink in the line or otherwise it can cause issues... just replace and be sure to keep the ends clean and dirt free. Things happen even when they are not moved or touched.. try to troubleshoot and good luck!

Of course - if the signal is weak and you're running too far it can cause issues too.. again - a better cable with lower impedance can help there too. Always check sync freq and normal driver updates too. That's a no-brainer... keep your drivers up to date. There's usually a reason a manufacturer releases a driver update when they take the time to do so. I use a couple tools from IOBIT to keep my family pc's up to date and running smooth. Love the one-click button options - super easy to use - Advanced System Care Pro. There is a free option too - but the pro is pretty cheap and well worth it - and can be installed on several PC's if I am not mistaken...

Let us know how it works out!

0

I've been troubleshooting this issue all day and thought I'd add some more steps to check.

I have 2 Dell S3221Q monitors connected over DP with only one of them going black intermittently. Cables/card/ports all checked and ruled out. The issue seemed to be a combination of using the Default "Generic PnP Monitor" driver (Have installed the driver from the dell site now) and the refresh rate being slightly different on the monitors. The working monitor had a refresh rate of 59.997Hz and the faulty one was set to 59.940Hz. I had not changed these settings since setting the monitors up so not sure why Windows changed it.

Not the answer you're looking for? Browse other questions tagged or ask your own question.