4

My network:

192.168.2.2 (computer)
255.255.255.0 (mask)
192.168.2.254 (gateway)

The VMplayer is:

192.168.233.129 (ip)
255.255.255.0 (mask)
192.168.233.255(bcast)

It's obvious the player can't be access from other systems because of the wrong network settings. However, I am not sure as to how to change that. Obviously I have to edit the ifcg-eth0 but I know I also need to edit it on the host system to make it accessably.

Is this done from inside VMware Player? Or do I need to edit the network devices?

The host box is Windows. Inside VMware is Linux.

migrated from serverfault.com Oct 20 '12 at 23:51

This question came from our site for system and network administrators.

4

Your guest in your VMware player is inside it's own (private) network, and connected outside via a NAT-ted connection.

You have to reconfigure network settings for that guest, and select bridged network (bridged interface or something simmilar in your settings), and bridge it to your hosts ethernet card. Then both the host and the guest will be on the same LAN (the one where your host is now), and your guest will get an ip from the 192.168.2.0/24 range.

If you cannot add the guest to your existing LAN, and just wish to access it from the host, you can add a host-only network interface, and set up a new lan (choose a subnet, set IPs), just between the host and the guest, but if you wish to have internet access from the guest, you'll have to set up internet connection sharing on the host.

  • Wow that was easier then I was making. – Tiffany Walker Oct 16 '12 at 17:04
5

Right now your VMWare Player VM is set to use NAT for the network interface. Set it to bridged instead and it will appear as a node on your network.

  • I cannot change it, is it because I am using a free version of the VMPlayer (12.5.7 build-5813279)? – eeadev Aug 2 '17 at 10:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy