I had few files and folders on the Desktop. I pressed the Delete button and the file/folder got deleted.

Windows 8 didn't ask any confirmation if I want to surely delete or not. Why is that so? Can this feature be turned on?

As per this Build Windows 8 blog post, the delete confirmation dialog was removed after lots of user request. This is because it will anyways be present in your recycle bin for you to recover it in case you accidentally deleted any file.

Finally, in addition to these big improvements, we’ve also done a thorough scrub and removed many of the confirmation dialogs that you’ve told us are annoying or feel redundant (i.e. “are you sure you want to move this file to the recycle bin?” or “are you sure you want to merge these folders?”) to create a quieter, less distracting experience.

All of this adds up to building a significantly improved copy experience, one that is unified, concise, and clear, and which puts you in control of your experience.

In case you want to enable it:

  1. First off, right-click Recycle Bin and select Properties. You can also access Recycle Bin Properties from within the Recycle Bin from Recycle Bin Manage tab.
  2. In Recycle Bin Properties dialog, enable Display delete confirmation dialog option and click OK to apply the change.

Instructions where taken from this post.

  • Could you please edit your answer to include a brief summary of the instructions from that post on how to enable it? We like to have all answers include enough information to solve at least the basic problem without having to go off-site. – nhinkle Oct 22 '12 at 4:13
  • @nhinkle As per your suggestion, I have included a short How-to in the answer to enable the confirmation dialog. – Ganesh R. Oct 22 '12 at 5:19
  • I have Windows 8.1 and I have selected this option. Sadly it makes no difference. The files go directly to trash. Any ideas? – jnovacho Jul 2 '14 at 16:46
  • @jnovacho I have Windows 8.1 Update 1. If I follow the steps I mentioned, I do get a delete confirmation dialog. – Ganesh R. Jul 3 '14 at 3:07
  • Few restarts were needed for this option to take effect. Thanks for your concerns. – jnovacho Jul 3 '14 at 6:30

Right-click Recycle Bin Select Properties. In Recycle Bin Properties dialog, enable Display delete confirmation dialog option. Click OK to apply the change. It should fix your issue.

protected by DavidPostill Apr 20 '16 at 20:24

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.