Quite recently I noticed a huge CPU spike when watching Blip.TV on my Thinkpad T420 laptop, with Nvidia card and Linux openSUSE. Furthermore, connected with my upgrade to XHD screen resolution, I am simply unable to enjoy a smooth fullscreen video (and even without fullscreen it is not completely smooth!

There used to be a HTML5 blip.tv viewer, but not anymore. Do you of any workaround that would allow me to watch the videos using the browser's codecs or maybe starting mplayer to watch the video? Maybe somehow loading the iOS website version would allow me to enjoy the videos?

Note that my browser preference is Google Chrome.

PS. Even though downloading flv from Firefox works, this requires too many steps to be viable.

2 Answers 2


You can use Blip.tv Video downloader user script to directly download the video from the website.


  • 1
    I would only add that a Tampermonkey extension is needed to load the user script! Very good solution, you can even click on the given links and watch in the browser! Thank you.
    – RushPL
    Oct 26, 2012 at 20:41
  • 1
    Unfortunately out of date. I am currently watching blip.tv by emulating iOS via developer tools.
    – RushPL
    Dec 18, 2012 at 22:21
  • Thanks @RushPL that works well. For others, Chrome Dev Tools > Cog (bottom right) > Overrides > Choose an iOS User Agent > HTML5 Player
    – jpillora
    Sep 26, 2013 at 2:39
  • Glad to help. Thanks for your comment. I almost forgot that I had this setting, so well it works.
    – RushPL
    Sep 27, 2013 at 9:59

Google Chrome has some issues with the Flash plug-in.

Maybe you could try typing in the search bar at the top chrome://plugins and then press the +details button in the top right.

You should then see your flash plugins that Chrome is using - if there are 2, disable 1, preferably the one that says 'pepflashplayer.dll' and just use the stand alone flash plug-in stored on your computer!

Hope this helps!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .