7

I have a Dell Precision M4600 (with capacitive touch screen) running Windows 8. Normally, I connect two monitors via docking station and keep my laptop closed. When I undock and use the laptop without touching the screen, everything works fine. But when I touch the screen for any reason, after a while (between 3 and 6 different touches) the screen will start registering touches all over the place, though mostly at the top. This means windows randomly open and close, which of course renders the computer unusable. After a reboot the behavior will start again (if I begin to touch the screen).

There used to be a way to turn off the touchscreen, but this option is gone in the RTM. Win8 Touch Settings
Dell "does not yet support Windows 8" and would require me to install Windows 7 before they will troubleshoot a hardware problem.

Any ideas on what to try to either a) prevent this from happening while using the touchscreen or b) disable the touchscreen when this starts happening?

1

Check the refresh rate of the monitor. It can sometimes reset to 40 Hz. It should be at 60 Hz to work normally. This fix has worked for me.

2

First, make sure your screen is clean and there is no debris hidden at the top.

Second, the screen may need to be (re)calibrated. You also might try clearing existing calibration data and recalibrating the screen.

On this page there is a "To adjust calibration" section that tells you what options to go to. This is for Windows 7, I'm betting it hasn't changed for Windows 8 (I could be wrong):

  1. Open Tablet PC Settings by tapping the Start button , and then tapping Control Panel. In the search box, type Tablet PC Settings, and then, in the list of results, tap Tablet PC Settings.

  2. On the Display tab, under Display Options, tap Calibrate. If you're prompted for an administrator password or confirmation, type the password or provide confirmation.

  3. Follow the instructions on the screen, and then tap Yes to save your calibration settings.

Notes • To perform a 16-point calibration again, in the Tablet PC Properties window, tap the Reset button. If you're prompted for an administrator password or confirmation, type the password or provide confirmation. Tap OK, and then tap the Calibrate button.

• If you begin a 16-point calibration and your screen is set to Portrait orientation, it will change temporarily to Landscape during the calibration.

Try doing the "16-point calibration" it talks about.

If the screen behaves erratically after that, I'd say it's defective and needs to be serviced and/or replaced.

  • cleaning the screen was the first thing I tried. Only calibration I see is to Calibrate Color. I will try again when I'm ready to undock. – Nathan DeWitt Oct 23 '12 at 14:45
0

What I always do, when I have errors such as phantom touches on my Toshiba (I known your running Dell, but hopefully it is simular) portege Z10t model a, is open the charms bar (move your mouse to the bottom left corner of screen, and then up) and then search "Drivers". I then click on Update Device Drivers, and click on "Human Interface Devices". This opens up a tab, where you should find an option such as "HID-compliant touch screen" or "TouchScreen" (or something simular, it differs on all computers) and right click this. Then select disable. This will disable your touch screen (If you have a pen that you use as a stylus, this will not be disabled).

I hope I helped,

Sincerely, Me

0

I had this issue on the right hand side i accidently left my chewing gum and closed it, when i reopened it in looked like the two layers on my lenovo touch screen was touching. after reading some comments and rebooting, it still didnt fix the issue.

so i thought to my self its stuck. i tried touching it there for a while it didnt fix it.

so then i pressed both of my thumbs on the screen and massaged around the place not on it and it fixed it.

0

I had the same issue with my Toshiba laptop. Here is what resolved the problem for me. Close all programs until you are on your desktop screen. If your unit is plugged in, unplug it. Next, hold the power off button for at least 30 seconds. Do not let your finger off the button even if the unit looks like it is off. Wait for 5 minutes. Power up your laptop again. The ghost bubbles should be gone. They are caused by excessive static electricity. Make sure to use your mouse on a rubber mouse pad or a surface that does not build static electricity. I was using my sofa, hence the problem began. Toshiba support was very helpful with this problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.