I'm having difficulty connecting Chrome to TOR. I started trying yesterday. I started Vidalia and TOR Browser and then followed the advice from here - downloading Proxy Switchy and setting it up as stated.

This resulted in Error 130 (net::ERR_PROXY_CONNECTION_FAILED) (in Chrome, when I tried to load a webpage). So I looked into Vidalia's settings and noticed that it appeared to be using port 9051, so I set that instead of 8118 as everyone on the internet seems to be suggesting.

Then I got a new error: Error 111 (net::ERR_TUNNEL_CONNECTION_FAILED). Digging a bit, I found that Tor should be set as a SOCKS proxy, not an HTTP proxy, so I unticked "use same settings for all protocols" in Proxy Switchy and just set localhost:9051 for SOCKS. That got me Error 7 (net::ERR_TIMED_OUT).

And that's when I came here for help. I typed up the above question, but then at the last minute decided to do a bit more reading and found someone here suggested using some command line arguments via a Windows shortcut:

"C:\snip\chrome.exe" --proxy-server=";socks=;sock4=;sock5=" --incognito check.torproject.org

And that worked perfectly. Yesterday. Today it doesn't, so I'm having to post this question after all. check.torproject.org gives me a "no" with Chrome, but a "yes" with the default Tor Browser. I tried closing Chrome and restarting it (yes, with the correct shortcut) after Vidalia started, but still nothing. The port number hasn't changed or anything. What gives?

EDIT: I realized I had a "non tor" instance of Chrome running and that possibly the was causing the command line args t be ignored when I started the new instance. Closed all instances of chrome and ran my Chrome Tor shortcut, and it did get rid of the "not using Tor" message -- because I got another Time Out error instead. Vidalia's bandwidth graph didn't even blink.


Try using switchySharp, I had the same issue in Proxy Switchy. For the SOCKS protocol, I'd suggest Polipo, which is quite fast.

  • I too had the Same issue with Proxy Switchy, I am using switchySharp without any issues.
    – HackToHell
    Jan 14 '13 at 5:00

On my configuration (the default that came with Vidalia, freshly installed today), 9050 is the port to use, and 9051 is the control port. Try pointing Proxy Switchy to localhost and 9050, like so:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.