2

My main rig had Windows go down and all I have is a blank flashdrive and a netbok with fedora running on it. I have the windows 7 iso ready to go. I tried unetbootin, but all I got was a blank boot menu.

1
  • Did you set the boot flag for the USB drive? That could be why you don't see any boot options.
    – Jay
    Oct 24, 2012 at 8:45

2 Answers 2

1

While I've used UNetbootin lots of times to create Linux LiveUSBs, I've never used it to transfer Windows setup to USB. Doesn't seem to be one of the things it's supposed to support, but maybe it has worked for some people.

Here's a slightly more lengthy process you can try, but it should work fine:

  1. Download and install GParted if you don't have it already

  2. Ideally, delete all existing partitions on your USB drive, then create a new partition, format as NTFS and set the boot flag from the Manage Flags dialog:

    enter image description here enter image description here

  3. Download and install ms-sys

  4. Enter su ms-sys -7 /dev/sdX at the terminal to write a Windows 7 MBR to your USB drive (where 'X' is your USB drive letter)

  5. Mount your Windows 7 ISO and copy all the files to the USB drive

  6. Boot from the USB drive and test

1
  • does not work. used xcdroast and dvdrw instead.
    – andrej
    Feb 28, 2017 at 12:38
0

You could use the Diskpart utility to format the USB flash drive to NTFS and create a primary partition. Note that you also need to make the USB bootable, in addition to copying the files, as mentioned here.

1
  • Diskpart is available on Fedora? Since when?
    – Karan
    Oct 24, 2012 at 20:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.