I have this board with IP address (can't be changed). I must connect to it via an ethernet cable and then use Modbus for communication.

I am currently having problems seeing this device on my network. My Linksys router has the IP address (pretty standard). The computers on the network have IP addresses and up.

I'm not really an expert in home networking, so my questions are:

  • Why do I not receive a response from the unit when I ping
  • Does it have anything to do with the fact that the device is on 192.168.5.* and the network "generated" by the router is 192.168.1.* and therefore can't see it?

My setup:

  • Connect device to router.
  • Ping the IP of the device - no answer.

Another test scenario:

  • Connect device directly to a laptop.
  • Change the computer's LAN settings to use the specific IP of the device.
  • Ping - no answer.

I also can't see the device when I go to the DHCP clients list in the router settings. Only devices on 192.168.1.* show up.

I have tried pinging the device from a laptop that's connected wirelessly to the network, and from a stationary computer that's connected with cable directly to the router. I've also tried to disable internet access from my external modem so the router didn't have internet access.


Does it have anything to do with the fact that the device is on 192.168.5.* and the network "generated" by the router is 192.168.1.* and therefore can't see it?


IP address ranges for private subnets (NATs) are specified by a subnet mask, which determines the valid range of IPs that are assigned.

Typically, in almost all cases, the subnet mask is, which means that you're using one number for the first three octets (the 255s), and all numbers for the last octet (the 0). So when you specify a NAT as having a gateway at and a subnet mask of, that means IP addresses through are valid on that NAT; due to the routing rules that are implied by the subnet mask, all traffic not occurring in this range is considered non-routable by the layer 3 switch within the router.

Your Linksys router should have a way, in its configuration page, to set the IP address range to through You can probably do this just by changing the router's IP address to and leaving the subnet mask alone (set at

  • 1
    Thanks, I had a feeling that I might need to change the IP address of the router. Changed it to and now I can see the board. Thanks! – eightx2 Oct 24 '12 at 14:55
  • Great news; you are welcome. – allquixotic Oct 24 '12 at 14:57

The device is on a different netowork so it will not be seen on the 192.168.1.X network. Changing your etherent address to one like and connecting may work but you may also need a cross over cable as the boardmay not support the direct connection. Connecting with a hub or switch in between may work if you don`t have a crossover cable. Also note that the device could be configured to NOT respond to ICMP. This is something I have seen and the device respond to an HTTP request on Port 80 but no reply to ping. Or it responds to a specific app used to control or manage the device.

You also might want to find the subnet the board uses. Could be set to something other than which would make selecting the IP for your laptop a bit more difficult. Using a smaller subnet is not unusual in industrial or controls installs

An alternative woyuld be to reset your router as noted by allquixotic

More info on the boardmay help refine the answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.