I've got a Packard Bell laptop with a Radeon 5650 card. The desktop resolution is 1600x900. Windows 7 SP1 x64.

I like older games. They often have resolutions like 800x600 or 640x480. When I run that, I get a small rectangle with the respective size in the center of my laptop's screen. This hurts my eyes because many details are so tiny to look at.

In my Catalyst Control Center, I have "Full Screen" scaling option:

enter image description here

This, however, seems to have no effect. The picture is centered, not scaled. Besides, the choice is greyed out and I can't change it.

But what I recently found out is that when I connect something to the laptop's HDMI output, I get the scaling I want on the laptop's screen. The HDMI device doesn't even have to be on or receiving HDMI data. I just plug it in, the screen blinks, and if I now run a full-screen game, it will be scaled to fit the laptop's screen.
For what it's worth, the HDMI is a separate desktop with a different (higher) resolution, not cloned.

Also, with an HDMI device connected, aditional panels appear in CCC; among them is the option to enable GPU scaling -- but that appears to only apply to the HDMI output, not the built-in screen.

Is there a way to force this scaling even when no HDMI device is connected? My current workaround is to plug my TV into my laptop whenever I want to play HMM 2, which is annoying a little bit, and besides, the sound also goes to HDMI, so I can't hear a thing.

I suspect the scale-or-center choice is stored individually for each possible resolution, is there a place where these can be edited manually?


This solved itself after an update of the CCC and video drivers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.