345

I need to send a CtrlAltDelete to a remote machine through Remote Desktop. The CtrlAltDelete is being intercepted by Windows 8, regardless of whether the remote desktop has focus or is in full screen. I'm remoting in to a Windows XP machine, and I've tried launching Remote Desktop through both the desktop and the Modern UI. How can I send a CtrlAltDelete?

I'd rather not install anything on the machine.

7
  • 3
    Is this through mstsc? or through the new Mondern-UI app? Oct 25, 2012 at 17:13
  • 2
    The special thing about Ctl-Alt-Del is that it's intercepted by the BIOS (hardware) at the local machine. So you can't actually send that. You would have to use some other key combination and send some kind of "reset" command to the remote machine.
    – Keith
    Oct 25, 2012 at 17:16
  • @JaredTritsch They seem to spawn the same thing.
    – rtf
    Oct 25, 2012 at 17:17
  • @Keith This was possible in Windows 7.
    – rtf
    Oct 25, 2012 at 17:18
  • 2
    What is the end goal that you need to achieve by sending CTRL+ALT+DEL ?
    – frozenkoi
    Oct 25, 2012 at 22:15

14 Answers 14

500

Try using Ctrl+Alt+End instead.

10
  • 4
    I was under the impression that the result would be a "real Ctrl+Alt+Delete". What's missing? Oct 25, 2012 at 17:15
  • 23
    What if you RDP into machine 1, and then use machine 1's RDP to remote desktop into machine 2. How do you ctrl+alt+del machine 2?
    – user785179
    Mar 26, 2013 at 23:37
  • 2
    @edymtt Just saw this comment... It's Fn+Right for the End button Jun 21, 2013 at 16:18
  • 43
    @user785179 on the first RDP session bring up the on screen keyboard applet, and click on the second (inner) RDP session, then click back to the keyboard and press CTRL ALT END with your mouse, which should send CTRL ALT END to the second RDP session. Convoluted, but just got me out of a jam Jul 17, 2013 at 8:11
  • 2
    On a Win 8 client running vanilla mstsc rdp'ing into a Win2003 server Ctrl-alt-end within the mstsc window does exactly what Ctrl-alt-del would do on the Win2003 server itself... Solved?
    – sal
    Aug 22, 2013 at 8:54
73

If you're using an RDP within another RDP, Ctrl+Alt+End may not work as expected -- it sometimes could bring up the Task Manager / Change Password screen for the outer RDP.

Instead, to bring up the Task Manager / Change Password screen for the inner RDP :

  1. Bring up the on-screen keyboard (Start > Run, type osk.exe)

  2. Hold Ctrl+Alt on the top-level machine and click Del on the OSK.

This should work for any number of nested RDPs.

5
  • This will only work if you are actually able to run a program. In emergency situations when there's no Desktop and no Menu Button, the mentioned Keystroke seems to be the only option.
    – PoC
    Nov 25, 2018 at 15:32
  • 1
    Found this useful for a password reset, using Xfreerdp to connect to Windows.
    – Sobrique
    Mar 25, 2019 at 9:33
  • 1
    lifesaver if you need "remote desktop" inside "remote desktop" Apr 2, 2020 at 8:00
  • 1
    This worked for me using xfreerdp through pcoip, thanks! May 29, 2020 at 5:11
  • 1
    This just pops up a a cryptic notification saying "To use the commands available when you press Ctrl+Alt+Del, click your user tile and choose an option" Apr 5, 2021 at 17:10
50

On a Mac, running OSX, try fn+ctrl+alt+delete

This works with Microsoft Remote Desktop client for OSX.

1
  • From there, the 'Restart' option is available under the Power menu in the bottom right corner. Feb 6, 2015 at 14:00
19

Scenario: Your PC (node_1) and Remote PC (node_2).

Open the onscreen keyboard Start -> All Programs -> Accesories -> Ease of Access -> On-Screen Keyboard on node_2.

When you want to send ctrl+alt+del, press Ctrl+Alt in node_1 and click del in node_2. (Worked for me in node_1=XP and node_2=Win7)

0
17

STICKY KEYS IS THE ANSWER

There is another way which will work regardless of OS and as many nested RDC sessions as you can wrap your head round. With the focus in the inner most RDC session, quickly press the shift key 5 times. This will bring up the Sticky Keys window, and one window for each level of nesting. When prompted to turn on sticky keys, click Yes/Ok for your most nested session, and No/Cancel for the outer sessions. Now with the focus still on the inner most nested session, press ctrl (then let go), press alt (then let go), press delete.

Tadah!

To turn off sticky keys, with the focus on the nested session, press shift 6 times and click No/Cancel.

6
  • This is not an answer to the original question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post.
    – DavidPostill
    Feb 4, 2015 at 17:15
  • 4
    I disagree. I don't have win7 to test the solution, but if it works as advertised, it does exactly what the OP wanted. May 25, 2015 at 2:28
  • 1
    Worked for me inside an RDP session within a VMware VM. Thank you!
    – jocull
    Apr 29, 2016 at 14:32
  • This works. Seems so damn clunky but, it is Windows. The nested RDP sessions are a pain. You'd think they could make an alternative.
    – andrunix
    Jul 1, 2019 at 14:57
  • This was the only answer that worked for me for a RDP inside a VMWare Horizon session inside a RDP (don’t ask why)
    – bugybunny
    Jan 21, 2020 at 10:00
14

It is CTRL + F1 for people using Citrix.

0
9

It isn't a very quick or graceful solution, but if Ctrl+Alt+End doesn't work for what you need, you can open the on-screen keyboard in the remote desktop, and click the Ctrl+Alt+Delete keys with the mouse.

4
  • 2
    doesn't work with Windows-8 (I'm not talking about RDC). On your Windows 8 system, hitting Ctrl + Alt + Del on would thrown a message asking you to use your mouse and click on the user tile:)
    – agirish
    Oct 25, 2012 at 17:15
  • @GrahamWager actually suggested this in chat. Unfortunately, it doesn't work.
    – rtf
    Oct 25, 2012 at 17:16
  • @AbhishekGirish Does Anup's workaround work on Win8?.
    – ruffin
    Dec 15, 2014 at 14:02
  • 1
    This works for Windows Core! It brings up a DOS shell with a menu of items.
    – redcalx
    Nov 3, 2020 at 19:44
6

You can also try installing Autohotkey on the server, and create a key binding that works to send Ctrl+Alt+Delete without Windows 8 intercepting it. A mini-tutorial is available as well

3
  • Pretty sure this doesn't work.
    – Bob
    Jul 15, 2014 at 13:59
  • 1
    The OP specifically specified 'no additional software'.
    – AStopher
    Jan 6, 2015 at 14:54
  • @cybermonkey not specifically, he requested it. Still doable Jan 6, 2015 at 15:35
4

Hope it will help for Windows 8 too.

Problem

Unable to use Ctrl+Alt+Del feature on remote desktop running Vista OS/ Windows 7/ Windows 2008.

Cause

Problems to use Ctrl+Alt+Del feature on remote desktops running Vista OS/ Windows 7/ Windows-2008 may occur due to one or more of the following reasons:

  1. User Access Control(UAC) is disabled in the remote machine running Vista OS/ Windows 7/ Windows 2008.

  2. Secure Attention Sequence(SAS) is disabled in the remote machine running Vista OS/ Windows 7/ Windows 2008.

Resolution

Enable UAC in the Remote Desktop running Vista OS/ Windows 7/ Windows 2008

Goto Start → Run → type msconfig. This opens the System Configuration Window.

Click on Tools tab.

Locate and Click

on "Enable UAP" or "Enable UAC" option item. This opens a Command Prompt window that automatically executes and runs certain process to Enable UAC.

Close the cmd window when done. Also close msconfig window.

Restart the computer for the changes to apply.

Set the Policy :

Execute Gpedit.msc from Run prompt.

Goto "Computer Configuration" -> "Admin Templates" -> "Windows Components" -> "Windows Logon Options"

In Windows LogOn Option , double click "Disable enable software Secure Attention Sequence" Select "Enable" option and "Services and Ease of Access application"

Click OK.

Source

3
  • What if remote machine is not running windows? Mar 11, 2013 at 8:36
  • Good question, I never thought about it. I think in that situation we have to find another solution. :)
    – avirk
    Mar 12, 2013 at 3:35
  • 1
    "Disable enable software Secure Attention Sequence" Select "Enable" - had to read that 3 times to understand it! Sep 19, 2013 at 11:22
3

CRTL+SHIFT+ESC, process manager skips that window.

In the run window for rebooting a windows server:

Shutdown -r

For shutting down:

Shutdown -t
1
  • Due to a weird situation, I had to RDC from my Mac to a Windows PC, and then from that Windows PC into another Windows PC. When the Explorer on the third PC in the chain hung up, this was the only answer that saved me. Sep 11, 2014 at 18:09
3

When logged into the remote Windows PC, right-click on the bar the bottom, which will bring up a number of options and one of them is "Show Task Manager". Hope this helps.

1
  • 1
    That's not the only thing you do with ctrl alt delete Jan 6, 2015 at 15:33
3

In windows 7 hit the start button on the machine you are connected to via RDP and then click the "Windows Security" button which effectively is the same thing as pressing Cntl-Alt-Del.

1

Sometimes if all you can use is a command line, then you can paste

Powershell.exe -noprofile -nologo -noninteractive -command "(new-object -ComObject shell.application).WindowsSecurity()"

into CMD, PowerShell, or even the little program search text box that appears when you click the Start menu Windows icon. This simulates pressing Ctrl-Alt-Del.

I've been on servers where pretty much the only program available is the CMD shell. Makes no sense, but it's true.

1
  • This works! I am using Citrix and this is the only suggestion that worked for me. Even the on-screen keyboard option didn't work. Thanks
    – Kent Pawar
    Apr 8, 2021 at 12:21
0

I also had this problem, with client win8.1 and server windows server 2008 R2. And there was no way to open the screen to change the password remotely because no CTRL+ALT+DEL or CTRL+ALT+END worked both on client and on server. Opening the on-screen keyboard on server also didn't worked and nothing happend. For me, the solution was to open the on-screen keyboard on client machine, then open the remote window and press the CTRL+ALT+DEL set of keys and worked for me.

0

Not the answer you're looking for? Browse other questions tagged or ask your own question.