67

I can't disable the Microsoft Antimalware service (MsMpSvc/MsMpEng.exe). I tried using services.msc, but the Startup Type drop-down is grayed out and I can't change it to Disabled nor stop the service. I also tried msconfig, but when I click Apply, the service gets enabled again. I even tried net stop msmpsvc and got system error 5 (access denied).

Any suggestions?

  • Do you have admin rights on the computer? – salih0vicX Oct 27 '12 at 17:19
  • Yes, of course. – Italo Oct 27 '12 at 17:45
  • Which operating system? – user3463 Oct 27 '12 at 21:33
  • 6
    This is by design for most any anti-virus software. If turning it off were that easy, the software could not be effective against malware. – Joel Coehoorn Feb 4 '13 at 20:57
  • Install an antivirus application, such as AVG. – Andy Jun 5 '15 at 0:17
35

Just in case someone will face the same questions on Windows 8/8.1 - there is now build-in option to stop both Windows Defender-related services:

  • Windows Defender Network Inspection Service and
  • Windows Defender Service:

Turn off Windows Defender

  • 1
    Author is using Windows 7 not Windows 8 and your answer only applies to Windows 8. – Ramhound Apr 26 '14 at 23:11
  • 2
    It does not help for me (Win 8.1 prof). I disabled real time protection, turned off this app and there is still MsMpEng.exe consuming my CPU and disk. Computer is soo slow... – Tomas Kubes Oct 28 '14 at 19:56
  • @qub1n, well, this is kind of strange. It may sounds obvious, but have you tried to reboot your computer and after that check the check box from the image above? – Sevenate Oct 30 '14 at 17:01
  • Yes,I disabled it months ago. – Tomas Kubes Oct 31 '14 at 7:32
  • 2
    this answer works for Windows 7. I was able to Disable Real-time protection and uncheck the "Turn on this app" option. After clicking past the dire warnings, the icon removed itself from the task bar and the unstoppable Windows service stopped. – pdwalker Apr 20 '16 at 18:56
15

Another way to get around the protection:

  1. Go to options and
  2. Find where it says "Exclude files and folders"
  3. Then just add the "C:\" drive.

This way even if you can't disable it outright, it can't scan your computer at all.

Also do this for both Windows Defender and Microsoft Essentials.

  • 1
    Of course, don't forget to remove the exclusions once you're done with whatever you wanted to accomplish, otherwise it's as good as not having it installed at all. – Karan Jul 14 '13 at 3:55
  • 4
    Not having it installed at all sounds like exactly the solution to the problem. Anyone going to these lengths SHOULD know that they can't expect their babysitter to keep them from destroying their machine with warez and virusez any longer. – mightypile Oct 11 '15 at 17:10
  • 2
    That's not quite true +Karan, not having it installed at would be even better. – Jerry Asher Aug 1 '16 at 19:13
7

The best way to disable the Defender is to run regedit.exe, go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Defender, take ownership of this registry key (inside regedit.exe or via the 3rd party tool RegOwnershipEx) and set the values DisableAntiSpyware and DisableAntiVirus both to 1.

enter image description here
click to enlarge

Note, if you only see 1 of the values, change this one.

  • 1
    Appears to work under Windows 10, I think... – Andrew Dec 12 '17 at 4:11
  • 4
    @Andrew this question is for Win7,8. For Windows 10, go to HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows Defender and create the DWORDS here and set them to 1. – magicandre1981 Dec 12 '17 at 16:33
  • Yes, your answer doesn't change any. Thanks though! – Andrew Dec 16 '17 at 4:40
  • 1
    This doesn't seem to work. MsMpEng.exe still runs – rolls Oct 12 '19 at 15:27
  • 2
    @rolls Microsoft changes this from each windows 10 version to force users into their shitty program. I'm tired of updating this all time. Try the reg from this blog – magicandre1981 Oct 13 '19 at 8:30
5

Windows Defender/Microsoft Security Essentials is very tightly knit into the operating system in order to provide more security. It's best to disable it through the natural means than trying to cut it out piece by piece.

Go to your control panel, and select the entry for your Microsoft Antivirus. It might be listed as "Windows Defender" depending on your update history. Look in the 'settings' section in the Antivirus GUI for a "disable"

Depending on how updated your Windows Defender/MSE is, and how updated you received the program, these steps may vary, but the general idea is the same: disable it the way they provided you, not by trying to be crafty.

You'll find that many antiviruses will inject modifications into discrete crevasses of your operating system in the name of security.
Good rules of thumb to remember are to

  1. Always install, uninstall, disable, and so on, the way the manufacturer intended. If you fail to do so, and you don't know exactly what you're doing, start over. (e.g. Reinstall, then uninstall)
  2. Search for tools which allow you to clean up after failed operations. For example, Symantec provides the Norton Removal Tool, which will scan for leftovers of a damaged [un]installation and remove them.
  • 2
    Thanks for the advice, but that is not what I asked. I can of course uninstall it, and that's what I've been doing. But installing and uninstalling all the time is not practical. I am really looking for a way of disabling it temporally. – Italo Oct 30 '12 at 17:48
  • 2
    @Italo Disabling the antivirus via the GUI is a quicker and equally safe alternative to uninstalling. It's covered in my second paragraph. If you must use services.msc, run it as an administrator and disable the service. Note: If your username is not "Administrator", it means you are an administrator, and you must still open "services" by clicking "Run as Administrator" – jsvk Oct 30 '12 at 18:20
5

OK appears the UI has changed, at least with windows 10 "creators update":

Settings app -> "Update & Security" -> Windows Defender -> "Open Windows Defender Security Center" -> "Virus & Threat protection" -> "Virus & Thread Protection settings" (button) -> "Real-time protection" slide the selector button to "off"

Now MsMpEng.exe isn't using 100% cpu and system is faster (though unprotected).

For a disk intensive build my build times went from 8m33s to 1m49s whoa!

4

If you just want to shut it down temporarily:

1) Open the search bar (right side of screen)

2) Search SETTINGS and type in ADVANCED

3) Select "Advanced startup options"

4) Scroll to the bottom and select "Restart now" (computer will restart and bring you to the Advanced Startup options menu.)

5) Select "Troubleshoot" at the Advanced Startup options menu.

6) Select the "Startup settings" option.

7) Select "Disable early-launch anti-malware protection" (option #8)

8) Select the restart button and you'll be brought to windows.

Do whatever you want to do, and the next time you restart your computer it will be enabled automatically again.

3

On Windows 7, this MsMpEng.exe service is part of Microsoft Security Essentials (find it under Start > All Programs). You can disable its real-time protection, in the Settings tab:

enter image description here

However, this might not disable the MsMpEng.exe service from running, so you'd probably have to uninstall Microsoft Security Essentials for this matter:

enter image description here

  • 1
    Doesn't seem to still work for windows 10 :| – rogerdpack Dec 15 '17 at 12:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.