On Windows XP, SP3, I had 4 auto updates that would run and then immediately get scheduled again because they needed to run. No errors reported, they just ran over and over. I tried doing them manually, I tried downloading different versions of them and doing them manually, I disabled my virus software, I uninstalled my virus software, etc., etc. I worked on it off and on for months and never got a resolution.

I finally read about someone who uninstalled .NET Framework -- all versions -- and then the updates would run. I uninstalled .NET Framework and the update problem went away (not to say it won't come back).

However, now I can't get .NET Framework v4 to install again, and of course I have an application that requires it (TurboTax, if that makes a difference). I have downloaded full and network versions of the .NET Framework install, and get the same informative error message:

Installation Did Not Succeed

.NET Framework 4 has not bee installed because:

Fatal error during installation.

For more information about this problem, see the log file.

The log file is tens of thousands of lines; I did find:

Returning IDOK, INSTALLMESSAGE_ERROR[There is a problem with this Windows Installer package. Please refer to the setup log for more information.] MSI(C:\DOCUME~1\rcook\LOCALS~1\Temp\Microsoft.NET Framework 4 Setup_4.0.30319\netfx_Core_x86.msi) Installation failed.Msi Log: Microsoft >NET Framework 4 Setup_20121027_154208640-MSI_netfx_Core_x86.msi.txt

So I searched for and found THAT log file and it had something in it about an inability to update a file because it was in use by another process.

So I used msconfig to disable all startup processes -- since I didn't have any applications running, I figured it had to be something automatically started -- and rebooted, and ran it again. I got the same results, with different log file names, and now I can't find EITHER of the log files. I searched all directories under my (admin) user id for files ending in msi.txt - nothing.

Is there something I'm missing about installing this? I got version 2 installed, because evidently you can (or are supposed to) have multiple versions installed at one time. I got a similar set of errors on 3.5 on a previous attempt. Do I have to do 3,0 and then 3.5 and then 4.0, or something? None of the instructions I've been able to find say so, but then none of the instructions I've been able to find are working...

migrated from stackoverflow.com Oct 28 '12 at 5:16

This question came from our site for professional and enthusiast programmers.


I'd start by trying to install 3.5 Sp1 first: http://www.microsoft.com/en-us/download/details.aspx?id=25150, then move on to trying to get 4 installed. The versions are confusing, but i've gone from 1.1 to 3.5 sp1 without issue.

  • ok, tried that: "An error occurred during setup. Installed files have been removed from your computer. For known issues and troubleshooting information, see the online Readme. For error information see Error Log." The error log has "MSI returned error code 1603"; a site or two ids this as attempting to install to a folder that is encrypted, on a substitute drive, or for which System does not have full permissions. I don't know what folder it is they're attempting to use. I also notice the message refs ".NET Framework 2.0a" is not installed; is it trying to install that before 3.5? – rcook Oct 27 '12 at 22:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.