4

I have a dual boot system with Windows 7 and Windows 8.

After I shutdown in Windows 7, wake-on-lan works perfect but if I shutdown in Windows 8, it doesn't work. Even if I sleep or hibernate in Windows 8, wake-on-lan works.

Can anyone tell me why is this happening?

7

I found that it was related to the Fast Startup feature in Windows 8. After I disabled it, it worked fine.

Here is how:

  1. Press the Win + W.

  2. Type change power buttons and press Enter.

    S2

  3. Click Change settings that are currently unavailable.

    S3

  4. Uncheck Turn on fast startup.

    S4

  5. That's it.

  • This doesn't work for me, Fast startup was already turned on. – Caleb Jares Oct 28 '12 at 21:31
  • Oh, what does fast startup do? – Caleb Jares Oct 28 '12 at 21:32
  • Hmm, sounds like something I'd like to keep. Is there any way to have my computer able to wake when I try to remote desktop, but still keep fast startup? – Caleb Jares Oct 28 '12 at 21:37
  • 1
    Sleep and hibernate will work even with fast startup enabled. – Elmo Oct 28 '12 at 21:39
  • @Locutus Disabling fast startup has resolved my WOL issues just fine in Win 8.1 x64, so I'm afraid I have to disagree with you. – Martin von Wittich Sep 18 '14 at 12:21
7

http://support.microsoft.com/kb/2776718

"As a result, Wake-On-LAN is only supported from sleep (S3) or hibernate (S4) in Windows 8."

http://msdn.microsoft.com/en-us/library/windows/desktop/aa373229.aspx

"Remote wake from hybrid shutdown (S4) or classic shutdown (S5) is completely unsupported."

1

You can wake up computers with Intel's AMT Power On (vPro) or AMD's DASH, even with quickboot enabled. Just setting an admin password on a DASH enabled Broadcom card overrides Microsoft's command to turn off the NIC and traditional WOL starts to work again.

Intel's AMT will keep the NIC on if you set a password, but it didn't allow traditional WOL commands in our testing. There are command line tools to wake a computer by AMT if you know its AMT password/IP address.

  • Intel AMT
  • Power on the vPro computer
  • Press Ctrl+P before Windows starts to load
  • Initial Admin password is "admin"
  • Change the password to something else

Download the Intel AMT Development Kit  Use the remotecontrol.exe tool to wake computers.

RemoteControl.exe -changepower on -host 192.168.1.5 -user admin -pass AMTpass

You can reset the password by unconfiguring the card in the main computer BIOS.

AMD DASH Run the setup.exe that is contained in the driver download package for your computer's NIC (hopefully Broadcom). This will install the Broadcom Advanced Control Suite (BACS). This is required for other command line tools to configure the DASH chip.

Download the full Broadcom driver pack with utilities such as this one from HP. It will contain the BMCC.exe utility for configuring the default password.
http://h20564.www2.hp.com/hpsc/swd/public/detail?sp4ts.oid=7150467&swItemId=vc_147511_1&swEnvOid=4158

  • BMCC.exe edit
  • u (user accounts)
  • 2 (accounts)
  • 2. administrator account
  • 2 (enable account)
  • 4. try to change the password; doesn't work for me.
  • 0,0,0,q (quit and save)
  • Access http://computername:623
  • Logon as "Administrator" with no password (capital "A" required)
  • Change the password there.

You can export the account change and import it using BMCC.exe as well. This assumes that the administrator account is the second entry of the 10 in the list.

BMCC export=c:\dash.txt -record:40:2
BMCC import=c:\dash.txt -record:40:2

To reset the password for a DASH client you have to reapply the firmware update. This command came from the HP firmware update download for the Broadcom NIC. The ORY file is the firmware.

WinFWUpg.exe restorenvram update\KC381FAC.ORY idmatch config
  • i wish intel vPro would have a standard WOL compatible option. A setting that allows good old fashioned wake-on-lan packets to translate to whatever intel does to remote wake-up. It is a crime that millions of PCs were shipped with the Energy Star logo, but wake-on-lan would not work and no one knew why for many years. – rjt May 27 '17 at 15:44
  • The newest hp models we have, Elite Desk 800 G3 seem to supercede this nonsense from MS and allow standard WOL again. Perhaps some vendors are getting wise about what organizations want. I suppose it could be a security risk but only a minor one. More of a power usage money sink. – Iconiu May 28 '17 at 17:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.