After upgrading my computer to Windows 8 Outlook 2010 has stopped displaying search results. Normally you can enter a (part) of a word in the search box on top of the inbox list and it will show you result immediatly.

Even mails allready visible on the screen are not found.

Somebody familiar with this issue?


maybe relevant: I use an Google Apps Pro account. All mail is synced and locally available in Outlook 2010. I did not change this in any way while upgrading, it was working perfectly before. I can scroll through all the e-mails, new mails are coming in as expected.

This morning I received two mails from a person by the name of Rosanne. When searching on her name in Outlook it gives me One (1) result, the last mail from today.

Update 2: Rebuilding the index seemed to be working. But after another day it stopped working again. No results whatsoever in Outlook search. Rebuilding indexes every day is not an option as it takes several hours.

I suspect it has something to do with the fact that I use Google Apps Pro. It acts like a Exchange server to outlook. In indexing options (configuration) I added the directories containg the PST from this service (mail is also synced locally)


Looks like Outlook indexing might have an issue. Can you try to rebuild your index according to instructions here and see if it works. And do new mails that come after the rebuild appear in search now? Instructions seem outdated but might still involve similar steps

  • Close Outlook
  • Go to control panel
  • Go to system maintenance > Indexing Options
  • Click Modify, select the check boxes for the locations you want to index, and then click OK.
  • Click Advanced.
  • Click Rebuild.
  • Restart Outlook.


There seem to be some(outdated?) issues with Google sync and windows outlook search, as indicated here (scroll down to "Google Apps Sync Disables Outlook Search").

You can check by verifying if the Key PreventIndexingOutlook at the path HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Windows Search in Registry is set to 0 or 1. If it is one, reset to 0 to fix.

Edit2: Comments seem to indicate the registry key no longer exists.. im at a loss.

  • Good suggestion, reindexing as we speak. This takes a while, so I'll be back. – Klaaz Oct 29 '12 at 20:30
  • And solved! Reindexed it and it worked again! – Klaaz Oct 29 '12 at 21:53
  • And broken again the next day... – Klaaz Oct 31 '12 at 10:37
  • is automatic indexing.. disabled by any chance? Is anything on this page helpful? – Karthik T Oct 31 '12 at 10:44
  • Yes it was. Fiddled around a lot and it seems to work again. Thanks again! – Klaaz Nov 1 '12 at 11:51

Check your PST files for corruptions. I've been experiencing a similar problem recently, however the reason for it was migration from Outlook 2010 to 2013 and back. My OST file got corrupted and the search started to return no results.

The actual tool that checks for corruptions is called scanpst.exe and is already installed on your computer in the same dir as outlook.exe. For example, here:

C:\Program Files (x86)\Microsoft Office\Office14\SCANPST.EXE

If it doesn't help, there is a good source article with several other possible solutions.

Update: it was actually an OST file that was corrupted, not PST.

  • No corruption in my case, still, thanks for the suggestion! – Klaaz Nov 1 '12 at 11:52

I had this same issue, and I too rebuilt the index, checked for corruption, pretty much everything else here.

After that I took to the event log, in which I saw an error trying to index a List I had sync'd from SharePoint. I removed this list from the index and it seems to be working OK now.

Here is how:

Outlook 2010 > File > Options > Search > Indexing Options > Modify > Show All Locations > uncheck the sharepoint list > ok > Advanced > Rebuild Index > ok > close


i have similar issue with Outlook Contact Search. it became an issue after i migrated to Google Apps Sync for Business - Contact search doesn't work at all. i copied Contacts from Google Apps file to another PST file, opened it in Outlook and tried to search a contact - it works. the same search string doesn't work with Google Apps PST file, so problem in Google Apps


Local mail system: Mdaemon using IMAP for our clients Client System: Outlook 2010 Client OS Windows 8 Ent 64bit Client Machine: i7, 8GB, SSD the works

Outlook 2010 search has stopped working since the upgrade to Windows Ent. 8 64bit, after reading almost everything I could find on the web found nothing worked or even helped.

Seems that I may have this working by moving the index folder from it original location to c:\index

Here is how: Outlook 2010 > File > Options > Search > Indexing Options > Advanced > Index location > Select New > 'choose a location' > OK

Its got much further in indexing in 1hour that it has in over 6 weeks... still not fully indexed but thought I share.

  • After indexing, please restart windows and check if searching in Outlook still works. I still have issues. Only live search works, not the indexed Outlook mailbox. – Klaaz Mar 15 '13 at 9:23

Simple Outlook 2010 running on a Windows 8 desktop. Search would not work - found that if I changed properties, compatibility mode to run as Windows 7, it would work. However, other machines with same environment seem to work fine out of the box. Not sure why. Hope that helps.


I found that you have to change advanced properties of the file (.pst or .ost) to allow to index all contents of the file.

So just remove the Microsoft Outlook from indexing, then change the properties, then add the Outlook to the indexing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.