I have an ASUSN56V laptop with a GeForce GT 650M and i7-3610QM and want to use the card for calculations with CUDA. My impression from my scaling tests is that my GPU is not utilized to the maximum when running molecular dynamics programs with multiple threads. Specifically, I get a 3x speed up if I use 1 thread, the performance gain gradually drops and becomes worse with >4 threads. So my questions are:

  1. Why does nvidia-smi command prints just the TEMP, MEMORY and Compute M.? For the rest it prints N/A. Is it because the other features are not supported by this GPU?

  2. I tried to utilize all the computing power of the GPU by giving the following commands without any performance gains:

    nvidia-smi -i 0 -c 3
    nvidia-smi -i 0 -pm 1
    nvidia-smi -i 0 --gom=1

    The last one returned:

    GOM features not supported for GPU 0000:01:00.0. Treating as warning and moving on. All done.

Is there anything else I can do to benefit the most from the GPU during CUDA calculations? Unfortunately my BIOS menu does not support switching off the on-board graphics card and ASUS support said they cannot do anything about it.

I would greatly appreciate any advice!

  • in windows there is an option in explorer, "something like full graphics"? that you can set in the preferences for a shortcut to the app Oct 29, 2012 at 20:39
  • When you say 4 threads, are those CPU threads? When running a GPU app, the CPU must move new tasks to the GPU and copy new results from the GPU. If the CPU is too busy, it can cause it to keep the GPU waiting for those tasks to be performed.
    – Roger Dahl
    Oct 30, 2012 at 0:08

1 Answer 1


a gpu is a single threaded device so using multiple threads you are just slowing down the entire process. if you want to utilize all your cpu cores, use 1 thread to send commands to gpu and do the other things(non-gpu things) on other threads. if your integrated gpu supports opencl you can utilize that component too. so that would be 2 threads talking to 2 gpus and the rest doing the other stuff.

You must log in to answer this question.