15

I've got a machine on my home network running Windows Server 2012 (Based on Win8). The problem is, my taskbar disappears completely.

When I minimize an application rather than minimize to the taskbar it simply closes the window as small as it can as if the taskbar never existed (see photos at bottom).

The problem first presented itself after I accessed the computer from outside my local network I'm using a Linksys router and mapping to the server IP, port 3389.

After a restart the problem goes away, I will update when I have more information on how frequently or what may trigger.

Photos: Open window and no taskbar Effect of minimizing a window

5
  • First, try running a virus scan. This person had the same problem and solved it by removing a virus. Oct 29, 2012 at 23:35
  • @CMikeB1 what happens when you run explorer.exe? Is the correct resolution set? Oct 29, 2012 at 23:45
  • What happens when you go back to the physical connection (or an RDP session that has been known to have the taskbar) after having minimized an app from a session that doesn't have the taskbar? No taskbar there either?
    – ernie
    Oct 29, 2012 at 23:48
  • 1
    UPDATE: Back on my home network and the taskbar was still missing, even locally. Reset and problem is gone. I was wrong, this doesn't appear to be effected by RDP access, I will edit question to reflect. CalebJares, I'm having a hard time finding an anti virus compatible with Windows Server 2012. Louis, I will try that the next time the problem presents itself.
    – cmikeb1
    Oct 30, 2012 at 7:55
  • I'm with @Louis - this sounds like an issue of explorer.exe crashing or ending up in a weird state.
    – ernie
    Oct 30, 2012 at 15:53

4 Answers 4

12

I had the same issue.

The explorer.exe task crashed and the result was the situation described in the question above.

To solve this from RDP I used ctrl + alt + end (twice) then I selected the Task Manager option from the menu and from there I restarted the explorer.exe process by selecting File -> Run new task (I entered "explorer.exe" in the open text box).

2
  • 1
    This worked for me too, however in my case I couldn't get File->Run or Windows+R to open but I happened to have a command prompt up so I entered "explorer" to restart
    – Liath
    Apr 26, 2016 at 7:32
  • This will work until system is restarted
    – Imad
    Apr 1 at 10:22
4

Searching the problem, I saw other people with this problem, though on different versions of Windows, but the solution was in same.

  1. Open Task Manager
  2. Kill the explorer.exe process
  3. Restart explorer.exe from the File -> Run menu option in Task Manager

Source

Or....

  1. Press Ctrl + Alt + End
  2. Press Log off
  3. Then start a new RDP session and re-log in
1

I my case, the bar was there, but my host machine's taskbar was hiding it. What I did on the remote machine was window the RDP session, expand the taskbar (pull it up to make it bigger), and suddenly when I went back to full screen in the RDP session, my host machine stopped hiding the taskbar on the remote machine. Odd...

1

I got the same situation, (use Ctrl-Alt-Esc) Just open task manager. Right click explorer Choose restart explorer.exe

1
  • Right click on Windows Explorer then click Restart. If explorer did not work, then we should start it from File -> Run new task -> explorer.exe
    – Houmam
    May 8, 2018 at 21:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.