7

MSTSC (Microsoft Terminal Services Client, aka Remote Desktop) - mouse input works, but somehow keyboard input is locked. (I see desktop and can use mouse with apps but can't input a single character.) (All I remember - I set down onto the keyboard.. so it must have been a shourt cut) How to unlock?

13

Please go to:

Control Panel\All Control Panel Items\Ease of Access Center\Make the keyboard easier to use

Turn off Filter keys and check.

  • This resolved my problem with being unable to use my keyboard in a Windows Server 2012 remote desktop session. I must of somehow activated Filter Keys by mistake. Many thanks! – KingJ Nov 18 '13 at 2:56
  • Thanks. Mine was already off. I turned it on; saved it; turned it off and saved it back. – Ramnath Dec 2 '15 at 11:02
  • Sweet! Must remember though, it is turned on in your remote computer, not in your computer. I was turning on and off in mine... which ofcourse didn't work at all. – hina10531 Apr 27 '16 at 12:33
1

Firstly, I assume your keyboard is working fine for a non-RDP window.

While the RDP window is active, tap each of the left and right Ctrl, Shift and Alt keys. Also tap the Windows key, the Menu key (the other "new" key added for Windows) and any other modifier keys.

1

Faced the same issue. I rebooted the remote machine (a poor solution). That worked for me. Did not want to spend a lot of time in the net looking for a solution.

0

Please go to:

Control Panel\All Control Panel Items\Ease of Access Center\Make the keyboard easier to use

uncheck turn on mouse keys under control the mouse with the keyboard.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.