17

My file dialog shows files sorted by date and I want it to sort alphabetically by filename.

12

I was still getting inconsistent results with the various solutions. This seemed to work best for me:

  1. Open My Documents folder, Select View - Details
  2. Either (A) move Date column to the far left or (B) right click on date column, select "More" and move Date to the very top (Move Up button)
  3. Click on Date to sort by most recent
  4. Select View - Options
  5. Select View tab, Apply to all folders

This will always sort folders for that document type by date since it is the first column and saved as default view.

| improve this answer | |
  • Only solution here that works for me (Windows 7) – Stenemo Aug 17 '17 at 10:22
6
  1. Open Windows Explorer (WinKey+E)
  2. Click on the column you want to sort on (Name)
  3. CTRL-click on the 'X' close button at the top

Edit: This appears to be a folder by folder setting.

| improve this answer | |
  • This might have to be renewed from time to time, because Windows has a short memory. – harrymc Oct 1 '09 at 15:02
  • 6
    @djhowell: because we're too slow? – harrymc Oct 1 '09 at 16:11
  • I know he's technically right, but it's just a little abnormal to ask a (to my opinion very very simple) question and answer it within 2 minutes. – Ivo Flipse Oct 1 '09 at 16:38
  • 2
    @Ivo: Happens all the time when you're "stuck" and then figure something out, in my experience. – Andrew Coleson Oct 2 '09 at 2:18
  • 7
    @djhowell: It's OK to answer your own question: superuser.com/faq (last sentence in the first section) – Paused until further notice. Oct 5 '09 at 0:50
3

As seen at xpheads.com:

To resolve this behavior, reset the default sort order:

  1. Right-click Start > Explorer > C: partition
  2. View menu > Details
  3. Click the Name column to sort items by name > Hold down CTRL
  4. Quit Explorer via the X in the upper-right corner > Release CTRL > Reboot

NOTE: You must perform these steps exactly as they are listed; for example, do not quit Explorer by clicking Exit in the File Menu.

| improve this answer | |
1

This will sort all folders and files in same Order.

  1. Go to File Explorer (any drive)
  2. Right-Click and sort by (to any option you need)
  3. View pane > Options > Folder Options
    1. View > Apply to Folders > Ok
  4. Right-Click on the same directory > Properties
    1. Customize this Folder (Dialogue Box Opens)
    2. Optimize this Folder for General Items
    3. Tick Also apply this template to all subfolders
    4. Apply > Ok.

Now all of the files and folders are sorted in the same way.

| improve this answer | |
0

None of these solutions worked for me alone. I also had to change my folder type to "General Items".

  1. Right-click the folder and click Properties.
  2. Click the Customize tab.
  3. Under the first menu, Optimize this folder for, select General Items.

After this extra step, Windows Explorer always picked the sort order I'd set using the other solutions for this specific folder. Cheers,

| improve this answer | |
0

This works in Windows 10:

  1. Go to your top-level directory in Explorer
  2. Press Alt+V, Y, O to open Folder Options
  3. View tab > Apply to Folders

It should set the same view options you have in your top-level directory for the rest of the filesystem.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.