I somehow have set the default file type association for a file type in Windows 7. It doesn't appear to be possible to delete it from the "Change the file type associated with a file extension" options screen. Is it possible to remove it?

  • What is your Windows version (XP, Vista ...) ? – harrymc Oct 1 '09 at 15:46
  • Win7 - edited the question to reflect this. Note that the delete options in the file associations UI don't seem to be available in Win7. – Christothes Oct 2 '09 at 3:16
  • Related: superuser.com/questions/520193/…. It might be considered a duplicate, but it's newer and the answer there is not mentioned here. Basically it suggests to download and run a portable app (no installation required) that was provided by a Microsoft MVP. – Fabio says Reinstate Monica Feb 17 '16 at 10:17
  • This is better thread: superuser.com/q/569449/78897 – Pacerier Nov 26 '16 at 7:16

11 Answers 11

  1. Find the file extension in question under this key in the registry:


    Deleting the sub-key with the same name as the extension you want to un-associate will delete the default program association. In older Windows versions, you'll have to kill and restart explorer.exe for this to take effect (the change is instant as of Windows 10 64-bit).

  2. In most cases, you will also need to remove the same sub key from HKEY_CLASSES_ROOT as well.

  • 3
    @harrymc If your explorer.exe crashes, mostly it ill auto restart. Else you can start 'explorer.exe' via Run Prompt or task manager -> Application Tab -> new task -> explorer.exe – Ganesh R. Oct 1 '09 at 15:48
  • 1
    @Ganesh.R: In theory. In practice it can take some time to restart, and imagine the effect this will have on the OP. – harrymc Oct 1 '09 at 17:48
  • 5
    You may also need to remove an associated entry within the HKEY_CLASSES_ROOT key. I used your method above without also removing the related entry in HKEY_CLASSES_ROOT, and the user-specific subkey appeared again once I executed the file in question. I found it odd that the file icon did not change upon reboot when I used just your method. Anyways, thanks for the help! – Jonathan Nesbitt Nov 28 '12 at 22:45
  • 1
    The additional key removal suggested by @JonathanNesbitt was also necessary in my situation. Deleting the HKEY_CURRENT_USER sub-key does not appear to be sufficient on its own. – Iakovosian Jan 30 '13 at 11:29
  • 4
    This did not work for me. I needed to search the entire registry for the extension, and found an entry called "xxx_auto_file" under HKEY_USERS (where xxx was my file extension). I had to delete this to totally remove the ability to double-click on the file icon and have it open the application. – Mark Lakata Apr 19 '13 at 21:35

Even easier method that I found, it just requires the command line.

  1. Open a command prompt with Administrator privileges (right click > Run as Administrator).
  2. Run the command assoc .<file_extension> in the prompt. This will give the file type which is associated with the extension. If this command returns File association not found for extension .<file_extension>, it means the extension is not associated with any file type. If it returns an association value in format .<file_extension>=<Some Value> , then go to Step 3.
  3. Run the command ftype [FileType]= , where FileType is the file type returned in Step 2.

Special thanks go to My Digital Life for the instructions that I used to figure this one out. They also included a step that disassociates the extension from the file type, but based on what you are looking for, that isn't strictly necessary.

  • You should have cleared out that ext is an example and not a command that initiates the process. Anyway, that's a really good answer and goes straightforward to the solution. The link may go dead once, so if someone needs to associate an extension with null then he has to type: assoc .ext= then ftype WinRAR= to clear the program's associations. In my case didn't work for .localstorage (Mozilla's files fordownloaded content). So I used Christothes' answer. – Yannis Dran Dec 4 '15 at 8:05
  • It says File association not found no matter what. Even for the extensions clearly associated with programs. – stackexchange_account1111 Jul 1 at 4:12

In Explorer, go to Tools | Folder Options | File Types, find the extension you're looking for, and click Delete.

Or, if Delete is grayed out, click Restore (to set it back to the defaults), then Delete.

  • 7
    This menu is missing from Windows 7. I used Default Programs Editor utility as mentioned in several answers, such as this one: superuser.com/a/294490/38267 – goodeye Dec 11 '11 at 3:32
  • Wonderful. Did the job nicely (XP). And I didnt have to look regedit . – Plutonium smuggler Jun 23 '15 at 12:32

Why not use this method here:


Follow these very easy steps for changing the program that starts when you open a particular kind of file in Windows 7.

Here's How:

  1. Click on Start and then Control Panel.

    Tip: In a hurry? Type associations in the search box after clicking the start button. Choose __Make a file type always open in a specific program_ from the list of results and then skip to Step 4.

  2. Click on the Programs link.

    Note: If you're viewing the Small icons or Large icons view of Control Panel, you won't see this link. Click on the Default Programs icon and then click on the Associate a file type or protocol with a program link. Then proceed to Step 4.

  3. Click on the Make a file type always open in a specific program link under the Default Programs heading.

  4. In the Set Associations window, scroll down the list until you see the file extension that you want to change the default program for.

  5. Click on the file extension to highlight it, once you've found the one you're looking for.

  6. Click the Change program... button above the scroll bar.

    The Open With dialog box should appear.

  7. Look through the options in the Recommended Programs area and choose the application that you want to open the file extension with when you double-click on the particular kind of file on your computer.

    Note: Chances are, the applications listed under Recommended Programs will contain the most applicable programs for this file type but be sure to look at the applications under Other Programs. You may need to click the v to expand the list of these programs.

    Note: Click Browse... to search through your computer for any program not listed that you'd like to use.

  8. Click the OK button on the Open With window. Windows 7 will refresh the list of file associations to show the new default program to open this type of file.

  9. Click the Close button at the bottom of the Set Associations window. You may also close the Control Panel window if it's still open.

  10. From this point forward, when you double-click on any file with this particular file extension, the program you associated it with in Step 7 will launch and load the particular file.

    Important: Whatever program used to automatically open when these types of files were launched will still open these types of files. To use another program, you'll just need to start the program manually and then browse your computer for the particular file.

  • 1
    Welcome to Superuser. Please don't provide link-only answers, web pages move and links die so this answer may not be of any use to future visitors. Try adding a precis or abridged version of the contents of that link. – Tog Sep 21 '13 at 8:57
  • 8
    Good answer to get this hidden dialog in Win7. But it is only useful for changing the associated application, not for removing it. I had assigned Notepad++ to .bat. And then I didn't know how to remove this association to get the option to just run the .bat file. For this special case Christothes' answer helped me. – thersch Oct 16 '13 at 14:21
  • Changes are not taking place and still the older program remains as default even I commanded it to change to the newer one. – ankit Nov 4 '16 at 14:14

Similar to the top answer, but I find it best to only delete the UserChoice sub-key because you don't need to kill all of the info about the file extension (like the open with list), just the "choice the user selected" (aka-UserChoice). I use a REG file to make it fast to repeat for testing. You can copy paste this, including the version line, and save as a REG file. Just change .ics and .vcs to whatever extensions you want (or just remove one line if you only want to reset one):

Windows Registry Editor Version 5.00


If you aren't familiar with REG files, the above lines that start with "-" simply delete those keys from the registry.

Also, and the main reason I posted this answer, with this solution I don't have to restart explorer.exe. Maybe something specific to my setup, but I've used on Win7 and Win8 and never had to restart explorer.exe for the change to take effect.


I could not find the correct Windows Registry line, so I used a work around. On my desktop, I created a text file named "deleteable.txt". I changed the extension to .exe. Next, I used the control panel to change the default program assigned to the desired file extension to the new "deleteable.exe". I then closed the control panel, and finally deleted the desktop file.

  • Nice trick. I'll have to try it. – Kevin Fegan Apr 20 '13 at 8:05
  • Like that :-) Pretty straightforward too. Still, having an option to turn that stupid checkbox OFF by default would be even better :-) – Christian Stieber Jul 31 '13 at 21:02
  • This does not seem to work on Windows 7 (I tried on Windows 7 Enterprise 64-bit). When the fake EXE file is removed, it reverts to the previous association. – Peter Mortensen Sep 5 '13 at 14:54
  • Are there some requirements for this to work? 32-bit vs. 64-bit? Service Pack? Windows edition (home, professional, etc.)? User privileges? – Peter Mortensen Sep 5 '13 at 15:14

Safe brute-force method

None of the other answers' methods worked on their own for me when trying to delete the file association for something like .htaccess. This combined method worked (Windows 10):

  1. Create a new empty file called something like foo.exe.

  2. Go to a file with the extension you want to reset and Open with.... Make sure Always use this app to open .<extension> files is ticked. Then Look for another app on this PC and choose the foo.exe you just created.

  3. Delete foo.exe.

  4. Double click the file again and dismiss the Open with box (this might not be necessary).

  5. Now open regedit and delete the following keys:

  6. Log off and in again.


Creative Element Power Tools is a collection of productivity tools for Microsoft Windows Vista, Windows XP, Windows Server 2003, Windows 2000, and Windows Me. One of the file utility is File Type Doctor which allows user right-click any file and select Edit File Type to modify the applications used to open files of that type. Use File Type Doctor to choose default programs, add or remove file types from Explorer’s New menu, and customize files’ context menus.

alt text

More utilities here: Windows Vista File Associations Advanced Editing Management Tools

  • 3
    Nice, but not free. 45-day trial, $18 registration. FYI. – quack quixote Oct 1 '09 at 21:44
  • if a program is free, i usually add a footnote to my posts, and sometimes the old shareware motto applies: software worth using is worth paying for :) – Molly7244 Oct 1 '09 at 21:52
  • 1
    @Molly7244 The link is dead – Simon Sep 21 '13 at 8:50

My Solutions:

  1. Use this method of this question...but for some user it not work
  2. Another Solution:
    Search for php_auto_file in registry and delete entry. after explorer restart ..it's work
  3. Best Solution:
    Download nirsoft file type man(Description Link) , then open it ,click refresh icon,wait for refresh complete , find for example : .php extension ...and double click on this row...and now you see a dialog window...now check show this file type in the 'New' menu of Explorer

I did the brute-force ignorant method. Delete all registry keys that have the extension mentioned in them, as well as delete all the registry keys that have the previous application (bar.exe) mentioned in them.

Assuming the extension is .foo and the application is bar.exe, I think I found stuff here


as well as some other stuff that did not seem helpful to delete (a lot of MRU lists)

And I may have had to logout/login as well, although I'm not sure if that was 100% necessary.

  • 3
    “Brute-force” is right –– like a sledgehammer. This seems very dangerous; especially the part about deleting all registry entries that refer to the application. – Scott Apr 19 '13 at 22:27
  • I wrote the application, so I am less worried about it being dangerous. The issue was that I wanted to relocate the application to a different folder, but all efforts of trying to reassign it through the provided tools in the Control Panel failed. – Mark Lakata Apr 20 '13 at 4:27
  • 2
    Fine for you. My point is that your answer might be dangerous for Christothes or anybody else who has the same question. – Scott Apr 20 '13 at 19:22

Open a New Text File .txt and save it in desktop by give any name and extension as .exe and close it, open properties of the file which you want to change open with and in general tab click change in open with column click Browse and select your created .exe file and click ok it will change to your new created program and then delete your exe file that's it then when you open your file it will ask for open with.

Not the answer you're looking for? Browse other questions tagged or ask your own question.