I'm using Firefox 15.0.1 on Fedora 17 without running gnome or kde.

The problem I'm having is that whenever I select text outside of Firefox, for instance in xterm, the middle mouse button doesn't copy it inside Firefox, for instance in a text area, but rather brings up a context menu.

A related problem is that whenever I middle click inside Firefox, for instance in a text input, the middle mouse button brings up a menu when I'd like it to paste. Even if I select Paste in the menu not the selected text (from outside Firefox) gets pasted but the last selected text inside Firefox.

In about:config I tried "middlemouse.paste true" and also "middlemouse.paste false" together with the add-on Auto Copy but no combination worked. A middle mouse click always brings up a context menu. But the Auto Copy did help with automatically copying selected text to the clipboard. With Auto Copy the only problem I still have is pasting by middle button.

Follow up: somehow the problem solved itself. After removing Auto Copy firefox works as I expect it to (as any X application). I can't figure out why it was not doing it before, probably I was messing too much with about:config and not restarting frequently enough.

  • You should check if some of the add-ons is interfering with the normal middle mouse button behaviour
    – samir
    Oct 30 '12 at 12:52
  • I believe none of my addons do that, at least they shouldn't :) I have status-4-evar, oldbar, jsonview, firebug. Oct 30 '12 at 12:57
  • I am assuming this happens only in Firefox. Try disabling all addons, restarting Firefox and see what happens. If this still occurs, then it is not the addons issue. EDIT: my middlemouse.paste is set to true and everything works as intended. If i put it to false, paste doesn't work and no menu pops out.
    – samir
    Oct 30 '12 at 13:03
  • I removed the Auto Copy addon and now everything works as expected :) Don't ask me how, I don't get it either, the only reason I installed Auto Copy was to have this feature but now it works without it. Probably I didn't restart firefox soon enough after making changes to about:config or something. Oct 30 '12 at 16:53
  • I am glad that you managed to fix it.
    – samir
    Oct 30 '12 at 17:12

Even if I select Paste in the menu not the selected text (from outside Firefox) gets pasted but the last selected text inside Firefox.

X has up to three clipboards: Primary, Secondary and Clipboard. Clicking the middle button pastes the content of Primary, selecting paste from the context menu pastes the content of Clipboard.

To copy something to Clipboard rather than Primary, you have to press Ctrl ( + Shift ) + C or select copy in the context menu.

  • And there is no way to copy from Primary in firefox? Oct 30 '12 at 13:02
  • I'm sure there is. This was meant to be a partial answer, since I don't know how to fix the other issue. Middle-clicking works fine for me, but I'm using Ubuntu with Gnome.
    – Dennis
    Oct 30 '12 at 13:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.