I've been getting blue screens for several days now, only new thing I did was install a hard drive.

I'll be doing anything, browsing the web, etc. and I get a blue screen, that says CRITICAL_PROCESS_DIED on Windows 8 Pro. I checked the argument flags, its all 0's, which according to Microsoft says its a service that died, not a process.

At that point, it reboots, and I get another blue screen, that reads:

A required device isn't connected or can't be accessed.

During that time, my USB keyboard doesn't work, I had to hook up a PS2 keyboard to push the enter key to try again, or F8 for startup options. F8 does nothing. Enter throws yet another error:

The application or operating system couldn't be loaded because a required file 
is missing or contains errors.

The file in question is \Windows\system32\winload.exe

At this point, if I cold-boot, by a hard power-off and then power back on, the system comes up, until it blue screens again. Which can be anywhere from 5 minutes, to 2 hours.

So, I did all the standard debugging steps:

  1. I turned on memory dumps, and unfortunately, I get none, they don't work; the system apparently is dyeing before it does a dump.
  2. I checked event logs, the ONLY logs I'm getting from 5 minutes before I crash, to 5 minutes after are normal security logs, with the exception of after the reboot, where it throws the second two errors. At that reboot, I get a bunch of network connectivity issues, it cannot connect to anything.
  3. So I did a Windows 8 Pro "refresh", and same error occurred.
  4. So I decided I was done with that, I pulled out the new hard drive, did a CLEAN ALL on the original hard drive; ran a detailed SMART test, hard drive checked out ok, ran a detailed memory scan, it came out ok, ran memory and video stress tests, they came out ok, ran a CPU stress test and monitored CPU temps, never above 27 degrees. At this point, I thought, man, I got this; reinstalled Windows 8 pro, on the hard drive I had did a CLEAN ALL on, with a fresh Microsoft account; should have been starting brand spanking new at that point...everything went fine for about 2 or 3 hours, system ran like a dream; I started letting Windows Update run, installed office, and visual studio, ran great for another 2 or 3 hours, and then boom, crash again.

So my only hypothesis at this point, is one of the drivers installed by Windows Update, must be causing the issue.

Does anyone have any other suggestions of ways to get information out of the process, or at least help me figure out why memory dumps are not working? If I could get memory dumps to work, I know enough to be able to analyze the dumps, and go from there, but none of the dumps are working. I tried doing minimal, automatic, and complete dumps. I tried increasing swap file size, and changing the dump location, all to no effect, still don't have a single .DMP file on the PC.

System specs:

Operating System
    Microsoft Windows 8 Pro 64-bit
    AMD FX-8150 13 °C
    Zambezi 32nm Technology
    16.0 GB Dual-Channel DDR3 @ 798MHz (11-11-11-28)
    ASRock 990FX Professional (CPUSocket)   32 °C
    LCDTV16 (1920x1080@60Hz)
    AMD Radeon HD 6900 Series (ATI AIB) 41 °C
Hard Drives
    119GB M4-CT128M4SSD2 ATA Device (SSD)
    2329GB Western Digital WDC WD25 EZRX-00MMMB0 SATA Disk Device (SATA)    24 °C
    233GB Western Digital WDC WD25 00JS-60NCB1 SATA Disk Device (SATA)  33 °C
Optical Drives
    HL-DT-ST BD-RE WH12LS39 ATA Device
    Creative X-Fi Audio Processor (WDM)


Running AMD External Events Utility
Running AMD FUEL Service
Running Application Experience
Running Application Information
Running Background Intelligent Transfer Service
Running Background Tasks Infrastructure Service
Running Base Filtering Engine
Running Certificate Propagation
Running CNG Key Isolation
Running COM+ Event System
Running Computer Browser
Running Creative Audio Service
Running Cryptographic Services
Running DCOM Server Process Launcher
Running Device Association Service
Running DHCP Client
Running Diagnostic Policy Service
Running Diagnostic Service Host
Running Diagnostic System Host
Running Distributed Link Tracking Client
Running DNS Client
Running Function Discovery Provider Host
Running Function Discovery Resource Publication
Running HomeGroup Listener
Running HomeGroup Provider
Running Human Interface Device Access
Running IP Helper
Running Local Session Manager
Running Microsoft Account Sign-in Assistant
Running Network Connected Devices Auto-Setup
Running Network List Service
Running Network Location Awareness
Running Network Store Interface Service
Running Office 64 Source Engine
Running Peer Name Resolution Protocol
Running Peer Networking Grouping
Running Peer Networking Identity Manager
Running Plug and Play
Running Power
Running Print Spooler
Running Program Compatibility Assistant Service
Running Remote Desktop Configuration
Running Remote Desktop Services
Running Remote Desktop Services UserMode Port Redirector
Running Remote Procedure Call (RPC)
Running RPC Endpoint Mapper
Running Security Accounts Manager
Running Security Center
Running Server
Running Shell Hardware Detection
Running SSDP Discovery
Running Steam Client Service
Running Superfetch
Running System Event Notification Service
Running System Events Broker
Running Task Scheduler
Running TCP/IP NetBIOS Helper
Running Themes
Running Time Broker
Running UPnP Device Host
Running User Profile Service
Running Windows Audio
Running Windows Audio Endpoint Builder
Running Windows Connection Manager
Running Windows Defender Service
Running Windows Event Log
Running Windows Firewall
Running Windows Font Cache Service
Running Windows Management Instrumentation
Running Windows Media Player Network Sharing Service
Running Windows Search
Running Windows Update
Running WinHTTP Web Proxy Auto-Discovery Service
Running Workstation
Stopped ActiveX Installer (AxInstSV)
Stopped Application Identity
Stopped Application Layer Gateway Service
Stopped Application Management
Stopped BitLocker Drive Encryption Service
Stopped Block Level Backup Engine Service
Stopped Bluetooth Support Service
Stopped BranchCache
Stopped COM+ System Application
Stopped Creative Audio Engine Licensing Service
Stopped Credential Manager
Stopped Device Install Service
Stopped Device Setup Manager
Stopped Distributed Transaction Coordinator
Stopped Encrypting File System (EFS)
Stopped Extensible Authentication Protocol
Stopped Family Safety
Stopped Fax
Stopped File History Service
Stopped Group Policy Client
Stopped Health Key and Certificate Management
Stopped Hyper-V Data Exchange Service
Stopped Hyper-V Guest Shutdown Service
Stopped Hyper-V Heartbeat Service
Stopped Hyper-V Remote Desktop Virtualization Service
Stopped Hyper-V Time Synchronization Service
Stopped Hyper-V Volume Shadow Copy Requestor
Stopped IKE and AuthIP IPsec Keying Modules
Stopped Interactive Services Detection
Stopped Internet Connection Sharing (ICS)
Stopped IPsec Policy Agent
Stopped KtmRm for Distributed Transaction Coordinator
Stopped Link-Layer Topology Discovery Mapper
Stopped Microsoft iSCSI Initiator Service
Stopped Microsoft Software Shadow Copy Provider
Stopped Multimedia Class Scheduler
Stopped Net.Tcp Port Sharing Service
Stopped Netlogon
Stopped Network Access Protection Agent
Stopped Network Connections
Stopped Network Connectivity Assistant
Stopped Offline Files
Stopped Optimize drives
Stopped Performance Counter DLL Host
Stopped Performance Logs & Alerts
Stopped PNRP Machine Name Publication Service
Stopped Portable Device Enumerator Service
Stopped Printer Extensions and Notifications
Stopped Problem Reports and Solutions Control Panel Support
Stopped Quality Windows Audio Video Experience
Stopped Remote Access Auto Connection Manager
Stopped Remote Access Connection Manager
Stopped Remote Procedure Call (RPC) Locator
Stopped Remote Registry
Stopped Routing and Remote Access
Stopped Secondary Logon
Stopped Secure Socket Tunneling Protocol Service
Stopped Sensor Monitoring Service
Stopped Smart Card
Stopped Smart Card Removal Policy
Stopped SNMP Trap
Stopped Software Protection
Stopped Spot Verifier
Stopped Still Image Acquisition Events
Stopped Storage Service
Stopped Telephony
Stopped Thread Ordering Server
Stopped Touch Keyboard and Handwriting Panel Service
Stopped Virtual Disk
Stopped Volume Shadow Copy
Stopped WebClient
Stopped Windows All-User Install Agent
Stopped Windows Backup
Stopped Windows Biometric Service
Stopped Windows Color System
Stopped Windows Connect Now - Config Registrar
Stopped Windows Driver Foundation - User-mode Driver Framework
Stopped Windows Error Reporting Service
Stopped Windows Event Collector
Stopped Windows Image Acquisition (WIA)
Stopped Windows Installer
Stopped Windows Modules Installer
Stopped Windows Remote Management (WS-Management)
Stopped Windows Store Service (WSService)
Stopped Windows Time
Stopped Wired AutoConfig
Stopped WLAN AutoConfig
Stopped WMI Performance Adapter
Stopped WWAN AutoConfig
  • So it only does this on the new hard drive? or does it do the same thing when installed on the old one? – Moab Oct 30 '12 at 15:08
  • Windows was never installed on the new hard drive, the new hard drive is just a spare. The original hard drive Windows was installed on is the one that was causing the problem. – Brian Deragon Oct 30 '12 at 15:09
  • You have some hard drive device driver problem going on here, or possibly even lower down at BIOS level. Update your BIOS (after you do a full backup), and make sure you have the latest motherboard drivers. – user3463 Oct 30 '12 at 16:03
  • Done both already, wondering if I might have the opposite problem, if since this is Windows 8, that one of the newer drivers has introduced a bug. – Brian Deragon Oct 30 '12 at 16:13
  • The old drive might be failing, or you might have accidentally loosened one of the connections when installing the new one. SMART tests aren't usually exhaustive. Could be worth removing the old one and trying with just the new one. Could also be a motherboard or CPU problem. – Harry Johnston Oct 30 '12 at 21:03

Ended up finding links like the following:

Apparently, the Crucial M4 series of SSDs have an odd bug, even if they're not set to the boot drive, that they need to have their firmware updated or after approximately 5000 hours the drive will go into a healing/repair mode and shut down every hour, when it does, Windows 8 throws a CRITICAL_PROCESS_DIED blue screen.

Crucial has a firmware update that fixes it.

| improve this answer | |
  • 1
    This actually ended up being the problem I had with my SSD. I was searching for a solution when I found your problem. I was/am running Win7 though, so I didn't recognise the error. Thanks for sharing. I currently have about 5900 hours on my SSD. – Jochem Kuijpers Apr 7 '13 at 0:43
  • This happen to me, only once so far and i have a Crucial mx100 going to run a firmware upgrade hoping it wont happen again.. – Peter May 13 '15 at 17:46

What happens when you disconnect the new hard disk? If your computer still crashes and is unable to boot, it might be because the disk your operating system is on, is failing. It seems it stops responding when in use and only 'resets' when it has been completely shut down (cold boot).

To verify, you could boot any live CD or USB and access that disk. Just keep it busy until it stops working. If it doesn't stop working, it might be something else.

If the computer works fine without the other drive connected, check your BIOS for boot settings, be sure the right drive is selected. Also verify if the file windows is trying to load, is not corrupted. Open cmd.exe with elevated rights and go to system32. Then run sfc /scannow. This should scan all system-files for errors.

Also: Make backups of your data! (and don't connect or disconnect drives while the computer is powered on)

| improve this answer | |
  • 1
    Tried that, it didn't work, I did find out what the problem was, I'll post an answer shortly. – Brian Deragon Mar 29 '13 at 16:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.