40

I'm getting an error message mount: unknown filesystem type 'vboxsf' when trying to mount a shared folder on my guest Ubuntu machine.

I have a Windows 7 machine running 4.1.22V Oracle VM VirtualBox. I set up a shared folder (named shared) in the VirtualBox Manager and on the guest 10.04 Ububtu ran the commands:

mike@mike-laptop: ~$ mkdir win_share
mike@mike-laptop: ~$ sudo mount -t vboxsf shared win_share/
mount: unknown filesystem type 'vboxsf'

What's weird is with the exact same setup, but with my OpenSUSE 12.1 image, the same steps work. Any ideas why Ubuntu can't find the 'vboxsf' filessytem and what I can do about that?

EDIT
Based on the suggestion I got, I thought I would add there's no "menus" on the guest's virtual box window. Clicking on the "icon" in the top left simply gives "move", "max", "min", etc.

enter image description here

7
  • 4
    Have you installed the VBOX Guest Additions?
    – nerdwaller
    Oct 30, 2012 at 20:08
  • @nerdwaller - no, how do I do that?
    – Mike
    Oct 30, 2012 at 20:52
  • 1
    I updated my post, try out Host+D (Right Control +D) to see if it prompts for the install of guest additions. If it doesn't work, when I get home I can try to find your version of VBox and see if I can re-create the UI you're seeing.
    – nerdwaller
    Oct 31, 2012 at 19:31
  • Did that work? I could try it tonight if no.
    – nerdwaller
    Nov 1, 2012 at 5:11
  • @nerdwaller - the devices menu never showed for me, but I was able to load the Guest Additions via the VirtualBox Manager (loaded the CD .iso image) to the "storage" device. So that's in there and now unknown filesystem type is gone, but I'm getting protocol error instead. Any ideas on that?
    – Mike
    Nov 1, 2012 at 12:31

3 Answers 3

40

Try installing Virtualbox Guest Additions, it should take care of it.

  1. Start the Guest OS (UBUNTU)
  2. Click Devices in the top menu-bar (of the VBOX window housing Ubuntu)
  3. Click Install Guest Additions

VBox Install Devices Window

That should prompt the download of Guest Additions and may open up the nautilus Window when the download is finished.

At that point, if it does not install automagically - you may need to open a terminal and navigate to that folder and execute the bash with

sudo ./whateverTheArchitectureTypeYouHaveIs.sh

It offered to do it automatically for me.

VBOX Guest Additions Auto-Install Popup (note, it does require super user permissions in the guest os.)

Edit

Here is a windows screenshot (Version 4.2.4r81684 - however, I have seen the option since I can remember with VBox. Looks like others do not have menus either around the web, I'd like to disable mine for sure.), looks basically the same. You should be able to hit the Host+D keys to install them (sorry for overlooking that before). Host, by default, is Right Control.

Host + D

8
  • Thanks for the detailed information, but can you tell me where you're getting the "Devices" menu from? If I understood you correctly it should have been in my Guest's "window". I launched the guest and took a screen shot of what I was seeing (see edit). I'm not finding a "Devices" tab. Are you running a different version?
    – Mike
    Oct 31, 2012 at 12:27
  • Odd, in mine on W7, it looks similar to my screenshot above (from Virtualbox running on Arch). Try hitting your <HOST> + HOME on your keyboard (the default Host is Right Control) while in the VBOX. That should pop-up the menu-bar. Let me know if that does/doesn't work!
    – nerdwaller
    Oct 31, 2012 at 13:54
  • 1
    Edit: I am an idiot. There is a shortcut straight to installing guest additions... Hit <HOST>+D (Right Control + D). No worries on the menus, give that a shot.
    – nerdwaller
    Oct 31, 2012 at 13:59
  • +1 for the "Guest Additions". For some reason <HOST>+D didn't work, nor did the devices menu ever show. (I'll post an "answer" on how I got it working) but my mount still fails, for a different reason. :(
    – Mike
    Nov 1, 2012 at 12:32
  • What if you are on os x as a host?
    – trainoasis
    Nov 9, 2017 at 10:57
17

Maybe it's simpler to install the guest additions using

sudo apt-get install virtualbox-guest-x11

and then reboot.

2
  • it says "E: unable to locate package virtualbox-guest-x11"
    – ealeon
    Mar 4, 2018 at 4:22
  • Even I wasn't able to locate package, but after adding reference to stretch-backports in sources.list it started working i.e. deb http://ftp.debian.org/debian stretch-backports main
    – jeet
    Jun 5, 2019 at 12:13
6

So as per nerdwaller's post, I did need to install Virtualbox Guest Additions to get the vboxsf type in there... I still don't know why this is needed with Ubuntu and not OpenSUSE, but that doesn't really matter too much I guess.

None of the previous suggestions actually worked to get the guest additions installed. What I ended up doing is pretty simple:

On the Oracle VM VirtualBox Manager, when you click the Ubuntu virtual machine, you can select "Settings". This opens the following window:

enter image description here

As seen here, I clicked on Storage then the main IDE Controller (it was set to nothing) and I updated the CD/DVD Drive to point to: C:\Program Files\Oracle\VirtualBox\VBoxGuestAdditions.iso

Where the guest additions .iso was stored by default.

1
  • 1
    Right-Ctrl+C should get you the Devices Menu. From there you can install the guest additions.
    – user237382
    Jul 11, 2013 at 13:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.