This issue has occurred on both Windows 7 and Windows 8 machines. My computer is a member of an active directory domain Foo and I map a network drive using credentials to a remote domain Bar.

Anytime I reboot my mapped network connection to the Bar domain is lost.

When mapping the network drive I use Reconnect at sign-in and connect using different credentials. I enter the credentials and check mark save credentials.

Yet every time I reboot I have to go through this process again.

1 Answer 1


I experienced the same.

I think the reason is that on remote domain Bar you have some sort of access with your user credentials, but not enough to access the specific directory. I found this specifically with connecting to my NAS drive, where my logon name on both the NAS and my workstation are the same, but the passwords differ.

I got around this issue by using the free utility NetDrives. I know it is a separate application that is running but for me in my environment it works wonders. (There is just one bug in the app where Z cannot be used as a drive letter, due to an iteration issue, but since the source code is also available I fixed it for myself, and emailed the author of the app with the fix. Not sure if he implemented it)

Hope this helps and solves your issue.

  • Foo\me is a remote security user on Bar. Sigh stupid programmers ignoring why users input and doing what they want to instead. Commented Oct 31, 2012 at 16:26
  • I am going to check out NetDrives at home, I've had serious issues getting auth success to my QNAP NAS i built. Windows 7 seems to always want to send my workgroup name as part of the username regardless of anything i tell it to do. I even tried making the NAS share the same work group name but no difference, maybe this tool will actually let me specify a "username" truly by itself. Commented Oct 31, 2012 at 16:28
  • @ChrisMarisic It does for me. Hopefully it helps you as much as it is helping me.
    – Riaan
    Commented Oct 31, 2012 at 18:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .