2

Originally, the .sql file extension was associated with notepad.

I changed this by right-clicking on a .sql file and choosing "Open With" -> "Choose Default Program" to associate it with SSMS (SQL Server Management Studio) 2008R2. This worked fine.

Now SQL Server 2012 is out, I've tried to re-associate the .sql extension with SSMS 2012 using the same right-click method, however the new association never sticks, it continues to use SSMS 2008R2.
Any ideas on how to get it to remember the new version of SSMS?

I'm using Windows 7 Pro x64.

0

I used File Types Manager from Nirsoft to change the Edit and Open actions (including the double-click) from SSMS 2008R2 to SSMS 2012.
Everything works as expected now.

0

it worked for me by editing PATH variable. I changed it such that sql 2012 (110) comes first in PATH variable as below:

C:\Program Files\Microsoft SQL Server\110\Tools\Binn\; C:\Program Files (x86)\Microsoft SQL Server\110\Tools\Binn\ManagementStudio\; C:\Program Files\Microsoft SQL Server\100\Tools\Binn\;

after that when I reassociated the sql file with ssms 2012 it worked

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.