I installed "Visual Studio 2012 Express Desktop" on my "Windows 8 Pro". The installer succeeded and told me to restart the system. I obeyed.

Now the system hangs somewhere in the bootprocess and my eyes won't stop bleeding while looking at the dancing little dots (aka the "wait" animation).

After 2 resets the automatic recovery triggered and Windows 8 healed itself. Windows 8 booted again, I was able to login. I tried to launch Visual Studio, but some .dll was missing. I repeaired the installation via the installer. The installer succeeded and told me to restart the system. I obeyed, again.

And, again, now my eyes bleed again while looking at the dancing dots.

What is the problem? What is the best way to diagnose this?

Update: Maybe related, after the 2nd restore I get some 'COM surrogate crashed' messages from the picture viewer. And the "remove programs" panel takes ages to load.

Update2: After several cleanups / recovery / reinstall etc: VStudio now works. Boot-hanging might be coincidence and not corelation. I vote for closing this question, might be usefull for others in terms of 'it was asked but can't be answered'.

  • What version of VS 2012 are you installing? Ultimate, Pro, Express? Web installer or .iso? 32 vs 64 bit (not sure if they release 64 yet or not) Oct 31, 2012 at 17:56
  • @KronoS: express.
    – akira
    Oct 31, 2012 at 17:57
  • 1
    @KronoS: There is no 64-bit edition of VS.
    – SLaks
    Oct 31, 2012 at 18:03
  • @SLaks then why are they offering 32/64 VS 2012 Web? Oct 31, 2012 at 18:13
  • @KronoS: coz it contains 32bit AND 64bit compilers, yielding 32bit AND 64bit binaries.
    – akira
    Oct 31, 2012 at 18:31

3 Answers 3


There is a known issue with the Gigabyte motherboard, caused by an incompatibility of its on board USB3 controller.

See the last tip in the info below, from the emulator faq:

Problem: Installation of the SDK causes Windows 8 to fail to reboot.

This item is included in this troubleshooter because there is a known issue with Hyper-V interacting with third party software, and Hyper-V is used by the Emulator.

When this happens, restore your system by using the F8 option at reboot and choose the last known good OS instance.

Try manually installing the Hyper-V Windows feature before installing the SDK, via Control Panel->Programs and Features, “Turn Windows features on or off”.
Check whether you have any BIOS setting similar to: "Limit CPUID Maximum Value to 3". If yes, try setting it to disabled and see if that helps.

One possible root cause of this is if you are using a Gigabyte motherboard’s USB3 controller.

More information: Boot failure after installation of Hyper-V role on Gigabyte systems



I had the issue with my Gigabyte MB and now it's solved.

My issue started after the installation of the Windows Phone 8 SDK that activates the Hyper-V.

The issue is linked to that (even with the latest version of Windows 8): http://support.microsoft.com/kb/2693144?wa=wsignin1.0

First you need to download the latest version of the U1e(UEFI BIOS) on the Gigabyte website.

The archive contains 3 files that you need to copy on your USB stick but wait... You need to do something special and not just copy the files.

You need to create a bootable USB stick.

I used the Rufus tool for that: http://rufus.akeo.ie/

Launch the tool and choose the FreeDOS (in the dropdown). No need to change the default value for other options. When it's done, copy the 3 files from the archive you downloaded on your USB stick. If Windows asks, replace the autoexec.bat

Ok now it's time to reboot your computer.

Enter the BIOS settings and choose to boot on your USB device then save and exit.

The system will reboot on your USB stick and if you don't touch your keyboard the setup will start after a few seconds (I didn't choose the keyboard language, the setup started alone).

When the BIOS is updated the system will ask you to shutdown your computer and to remove the power cable. So turn it off, remove the cable, remove the USB stick and then plugin your cable and start your computer. The system will ask you to choose the default setup and boot/reboot -> Choose default setup with reboot.

Windows will boot, it will configure your system for a few minutes and then... Surprise! It's ok! (It was for me).

If you go back to your BIOS settings (after a reboot) you'll see that the USB3 controller is enabled by default.


Verify the integrity of the installation media. Try redownloading the installers.

  • i even consulted a diviner ... you spotted "update2", didn't you?
    – akira
    Nov 4, 2012 at 7:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.