7

I just bought a Wireless Router that has 4 Ethernet LAN Ports and one WAN port. The manual that came along with the Router asks to connect a Broadband (Cable/xDSL) modem to the WAN port. However, I do NOT have a Broadband modem. I use a 4G USB modem to connect to the internet.

What I would like to do is share my Computers internet over the Wireless Router.

What I've tried so far:

  1. Opened "Network and Sharing Center" (I'm on Windows 8)
  2. There are two adapters listed. One is the Computers Eternet adapter (I connected it to the WAN port of the Router) and the other is the USB Internet.
  3. Right Clicked on the USB Internet adapter -> Properties -> Sharing -> (checked) Allow other network users to connect through this computer's Internet connection

Expected Result: I wanted to be able to connect my Samsung Tablet to the internet by using the Wireless Router. But it seems its not working. The router isn't routing Internet.

What am I doing wrong? I feel the solution is simple enough, but I am totally new to networking. This is my first attempt really.

Any help would be hugely appreciated.

EDIT: After I did a bridge between the two connections, I lost internet connectivity. The following screenshot might help

enter image description here

With the bridge in place, I connected another PC to the router via an Ethernet cable. On that computer, IP addresses shown on the Router configuration page (192.168.1.2) seemed to be the right ones. However there was no internet connectivity on that computer as well.

  • Is the router set to get it's IP from your laptop (i.e. DHCP) or is it static? You should be able to check in the Router's Setup-pages. If this can even work (which it seems like it should), they would need to be on the same subnet. – nerdwaller Oct 31 '12 at 18:58
  • I tried Automatic. If I try static, it gives me some forms to fill up. IP Address, Gateway, etc. – Rakib Ansary Oct 31 '12 at 18:59
  • Looks like @SLaks got it for you, that makes sense. And yes, you want automatic so you are good there I think. – nerdwaller Oct 31 '12 at 19:00
10

I have finally come up with the solution. It's simple really, as simple as anything! Internet Connection Sharing is the way to go. This is what I tried earlier, but it didn't work before due to some errors in the Router configuration.

  • 4G Modem once connected will be shown in Network Connections as an Ethernet Adapter.
  • The WAN port of the Router should be connected to the LAN port of the Computer.

enter image description here

  1. Right click on the Adapter that is connected to the internet.
  2. Select Properties.
  3. Switch to the Sharing tab and check Allow other network users to connect through this computer's internet connection
  4. Its important to make sure that the router is configured to "Obtain IP Address automatically." This can usually be done by connecting the router to a PC via a LAN port and using the web browser. The details should be in the routers manual.
  • 1
    Close, but not quite there. The LAN port of the router should be connected to the LAN port of the computer. With this setup, the router isn't connected to any WAN. Connecting things this way will result in double NAT, which leads to all kinds of problems. – David Schwartz Sep 7 '15 at 3:36
2

Was trying to do the same thing. I have a Wifi adapter on my PC that connected to my buildings wifi. I needed to connect a printer to a router so I could print from my devices. This is how I did it.

  1. Set the router WAN to DCHP.
  2. Plugged the Router WAN port into my PC's Ethernet port.
  3. In the "Network Connects" settings I made sure that the "Share" was UNCHECKED for the wireless connection.
  4. Selected the Unknown connection (Ethernet Adapter) and while holding down the Ctrl key single clicked on the Wireless adapter (highlighting both).
  5. Right clicked one of them (doesn't matter which one) and selected "Create Bridge".

That was it. Works great.

  • Please don't add "thanks" as answers. Invest some time in the site and you will gain sufficient privileges to upvote answers you like, which is the Super User way of saying thank you. – DavidPostill Jan 26 '17 at 0:07
2

When you enable ICS on NIC#1, and Windows sets your NIC#2 to 192.168.137.1, go to your router config page, and manually set the router's ip to 192.168.137.2 /255.255.255.0 gateway 192.168.137.1

Leave the router DHCP on so that anyone who connects to the router will get a network IP address. I don't think your computer will act as a dhcp server in this instance.

Also, the computer in between the modem and router is isolated from everyone on the router.

This is a semi-working solution. What I wanted was for everyone to be on the same network, but this method does not do that. However, everyone does have access to the internet.

  • Router can also be on dynamic IP settings, which will do all the work, my tplink does it at least, just leave the NIC#2 to that IP you've mentioned. – JasonXA Aug 25 '17 at 22:59
1

Was trying to do same thing.I bought a 3G/4G Router (TP-Link MR3420)that has 4 Ethernet LAN Ports and one WAN port. The manual that came along with the Router asks to connect a Broadband (Cable/xDSL) modem to the WAN port. However, I do NOT have a Broadband modem. Initially I used a 4G USB modem to connect to the internet via router USB port but I needed to share My Mobile 4G internet with router via USB Tether. This is how I did it..

1.Connect the 4G phone to Laptop USB port and enable the USB tether on phone.In adapter setting lets refer this network as (Network#1).

2.Check the internet is working on laptop.

  1. In the "Network Connects" settings I made sure that the "Share" was UNCHECKED for the Network#1.

4.Set the router WAN to DCHP.

5.Plugged the Router WAN port into my PC's Ethernet port.

6.Selected the Unknown connection (Ethernet Adapter) and while holding down the Ctrl key single clicked on the Wireless adapter (highlighting both).

7.Right clicked one of them (doesn't matter which one) and selected "Create Bridge".

Now from another laptop or mobile log in to router admin page under WAN setting Detect the WAN Connection Type and let it refresh the following settings IP Address:
192.168.xx.xxx Subnet Mask:
255.255.255.0 Default Gateway:
192.168.xx.yyy

In few minute you should notice WAN internet light getting green from amber. Enjoy your new 4G internet setup.

0

Here are correct settings(if "obtain IP auto" doesn't work for you)

1.Set USB modem(or any other network that has access to internet) as sharing and connect a cable to PC LAN RJ45 and router WAN interface.

2.LAN network connection- click properties-->ipv4 networking and set these parameters

IP 192.168.2.100

Netmask 255.255.255.0

everything else leaves empty

  1. Open router web interface in a web browser (mostly 192.168.1.1 but may be different for your router like 192.168.0.1 ..etc) and set WAN settings to Static IP and set these parameters

IP 192.168.2.101

Netmask 255.255.255.0

Gateway 192.168.2.100

save...

That is it

-1

The method explained by Rakib Ansary works perfect. There is no issue of ip address assigning as mentioned by others. Let me explain how it happens in windows:

Suppose you have internet connectivity in Ethernet5, and you want to share it to Ethernet1. When sharing, windows automatically sets the IPv4 address of Ethernet1 to 192.168.137.1. (you need to connect the Ethernet1 LAN of PC to WAN of router, and set 'automatically get IP address' option in router settings).

Windows include a new virtual access point feature called Wireless Hosted Network. The default IP used by Windows is 192.168.137.1. However, you can change this IP to something else via Windows Registry changes.

Read more below:

https://msdn.microsoft.com/en-us/library/windows/desktop/dd815243(v=vs.85).aspx?tduid=(0f4300904671015c5b0cdec004df9cec)(256380)(2459594)(TnL5HPStwNw-jcY_Zuw.fFvRcHaZeflgPQ)()

  • This does not answer the author's question. You should edit this answer and provide specific and detailed steps on how the author solves their problem. If you are going to provide a relevant within your answer, you should quote and cite the relevant information, your answer by itself does not currently answer the author's question – Ramhound Jan 25 '17 at 15:55

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.