I saw this post and successfully added curl to my Windows command prompt as instructed.

However, when I attempted to run curl --compressed, it says:

"the installed libcurl version doesn't support this".

Is there something that I am missing? Most of the other commands I have tried work, so I am not sure what more I need to do.

4 Answers 4


Download cURL from here and if required, get the libcurl.dll as well.

  • 3
    Where to get libcurl.dll from ?
    – yarek
    Nov 22, 2015 at 20:34

That depends on how cURL was compiled (i.e. which options were selected, which libraries were involved, ...).

You could compile cURL yourself ensuring the options you need are enabled but I wouldn't recommended (it's a lengthy process and doesn't always end up well). If you need that option the one from here is the one I use. At the time of writing the version available there is 7.24 and at least curl_vista.exe supports that option.


I also use curl tool from MinGW64 - Minimalist GNU for Windows - brings a lot of other useful utilities. Just remember to modify your PATH to have MinGW64 bin folder higher in priority list than System32 folder and hopefully it will solve the issue.


While working on the docker getting-started tutorial, I ran into the {curl --compressed version error} implementing the "Using Bind Mount" section of the tutorial.

To solve:
In a MINGW64 'Git Bash' terminal I first ran the curl command without the "--compressed" flag, to update my curl version successfully. I then ran the command recommended by the error message originally seen: [ curl --compressed -o- -L https://yarnpkg.com/install.sh | bash ] This ran successfully, fixing the {curl --compressed version error}. Re-start my container in 'dev' mode with this command {without brackets} both mounted my dev repository directory and loaded the todo-db volume:

[ docker run -dp 3000:3000 -it --name containern-name
--mount type=bind,source="$(pwd)",target=/app
-v todo-db:/etc/todos image-name:latest sh -c "yarn install && yarn run dev" ]

It was great to see that the container responds immediately to code changes on the host computer as intended. The host machine is a Windows 10 laptop (Dell Inspirion dual core i7)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .