I have an SD card that has been used in a photo camera for some months, and it's been working perfectly fine until today. It failed when we were just browsing pictures in the camera screen (so it wasn't during a file write, it was just reading photos). One of the times we switched to the next photo, it didn't show up, showing an invalid card error message instead. I then tried it in a different camera, and got a similar error message.

So I tried to read it in a Windows PC, and since it couldn't recognize the card either, it offered to format the card. I of course declined this and tried GetDataBack for FAT, which couldn't recover anything at all and returned tons of read errors.

Then I tried ZAR (Zero Assumption Recovery), a recovery tool available here: http://www.z-a-recovery.com/download.htm

It took a very long time and then it just marked ALL sectors in my card as "bad sectors" (in a grid that represents the SD card sectors, all of them were red), without recovering anything.

I find it quite surprising that a perfectly good SD card can go from 100% good to 100% bad. I can understand some sectors eventually going bad but, all of them at once? The card wasn't mistreated or shocked, so I can't see how this could happen.

So, any chance I can recover the pictures in that SD card? I'm guessing not, but who knows.

  • 1
    Stupid question, but; is your SD card locked? Check the switch on it, I've gotten some weird errors with it locked before. – Simon Sheehan Nov 1 '12 at 0:37
  • No, it wasn't locked. So, I've just tried locking it and it looks like it's just as unreadable in either position. – OMA Nov 1 '12 at 0:44
  • Funny story. I once had an SD card corrupted, losing all my photos. I tried a lot of software to get them back, free and paid. Nothing worked. For two or three years I thought they were gone forever. Until one day the police imaged my laptop, and miraculously recovered all the photos. Every single one. I think it was AccessData they used. – Max Nov 1 '12 at 0:46
  • Well the police do have access to the most powerful recovery tools one can dream of, but these often cost thousands for a single-PC, one-year license. – Sylvester the Cat Nov 1 '12 at 0:49
  • What do you mean with "imaged my laptop". The photos were in your laptop or in the SD card? – OMA Nov 1 '12 at 0:50

What make/model is the card and where did you get it? Unfortunately, many cheap memory cards and flash drives on eBay tend to be fake (a small drive reprogrammed to masquerade as a much larger drive). As such, they look fine but cause all kinds of read/write errors when you try to use them.

Obviously you can’t use the advertised space, but it’s possible to reprogram it to reflect the true size and at least use that much reliably.

Before resorting to that, check that the card-reader is good by trying another card in it and trying the questionable card in another reader. It is possible that the reader has failed or, if you are lucky, its cable has come loose.

Also, check the contact pins on the card and the reader to make sure they are clean. For the card, just look at and wipe them. For the reader, use an emery board to rub them lightly. What likely happened in your case was that one (or more) of the pins were dirty or something and thus not making good contact with the readers’ pins. Either your sister cleaned them, or the repeated inserting caused the pins to get scraped a bit, wiping off the patina and allowing the electrical circuit to get made correctly. This makes sense because memory cards have several pins, and if some of them connect while others don’t, then it can result in a variety of symptoms including it being detected but unreadable as you saw.

| improve this answer | |
  • It's a 1 GB Kingston SD card bought at retail (IIRC), so it's not very likely to be a fake card, since it's not that large (just 1 GB in size), and has been filled lots of times previously with no problem. I also tried 2 different SD card readers with no good result. BUT, something odd has happened. After lots of tries, my sister put it back in the camera and it miraculously started working again! Not only that, but then she put it again in the PC and all pictures were readable!!! I can't understand what's happened here. How can a card go back from 100% bad sectors to 100% readable?? WTF?! – OMA Nov 8 '12 at 0:31
  • 1
    It’s actually not that surprising. I added an explanation of what likely happened. – Synetech Nov 8 '12 at 1:16
  • Thanks for your explanation. Well, AFAIK it wasn't cleaned, so it might be the repeated inserting which "cleaned" the card (though it apparently looked fine all the time). I'll try cleaning first next time an issue like this happens. Thanks for the tip. – OMA Nov 8 '12 at 1:34
  • 1
    No problem. It doesn’t have to look dirty, it can simply have a typical light, transparent patina (as metals tend to accrue) that impedes the electrical connection. – Synetech Nov 8 '12 at 1:40

It is possible that the card just packed it in, as storage devices will inevitably do. I had a similar problem once when using my laptop. It was purring like a kitten one second, then out of the blue the whole OS failed to respond (totally, as in not even the mouse would move). Several scans (quick and in-depth scans) on the HDD determined it had failed – that's how suddenly storage devices can fail. It doesn't have to happen on a write cycle either (i.e., file system corruption). There are other causes of failure.

Hopefully, for your sake, this is not the case. Try Piriform Recuva to attempt to recover the photos. I've used it, and it's pretty good. Failing that, they may be gone for good.

| improve this answer | |
  • 1
    Thanks for your answer. Well, it seems we got lucky, and after lots of tries in the PC, my sister put the SD card back in the camera and it miraculously started working again! Not only that, but then she put it again in the PC and all pictures were readable!!! I can't understand what's happened here. How can a card go back from 100% bad sectors to 100% readable?? WTF?! Anyway, thanks for the link to Piriform Recuva. Might come in handy next time some similar problem arises. – OMA Nov 8 '12 at 0:35
  • most likely, it was fine the whole time. possibly dust, or just went spastic like technology does tend to do. but yes, electronics do tend to do that sort of thing – Sylvester the Cat Dec 30 '12 at 11:55

As an EE, I have seen SD contacts as well as connector contacts (HDMI, etc) contaminated with solder flux, icing from donuts, etc. The first step is to clean the contacts both on the SD Card and the receptacle (camera in this case) with an electronics type cleaner (carefully and sparingly). The card should be cleaned before moving it to a PC or other device, or you may just spread the "plague" to another device.

If the card starts working for no identifiable reason - get everything you can off of it before it fails again. There may be an intermittent contact/circuit inside the part that may be affected by temperature or handling and you never know when it may fail again. Get the goods and then throw it away!

| improve this answer | |
  • Thanks for the answer. I suppose the card was slightly dirty somehow (though it failed while being read in the camera for some time without problem, not immediately after inserting it in the camera, so I'm not sure if it was due to fingerprints in contacts). Anyway, luckily the card was readable after some insertions/ejections, and we could retrieve all pictures back. – OMA Feb 7 '13 at 0:02

YES. It is possible that the card can go from 100% working to 100% bad sectors in a fraction of a second. There can be a number of reasons for this, but the most common reason is ESD. ESD is Electro Static Discharge. In other words, to zap your card: Walk on a synthetic carpet, make sure you wear some synthetic closthes too, then charge yourself with static electricity and finally, when you're charged, touch one of the SD card terminals. You will generate a spark which is more than 2000 Volts. Most of the time, such sparks are more than 10000 Volts. Now, imagine that you zap the chip. If a card does not respond to any input/output at all, all your computer or camera will read is bits that are set to one. Eg. %11111111 for a byte, which translates into 0xff. Since the "bad clusters" are marked (in the FAT) using the value 0xffff, you will see only bad sectors. This indicates that somehow, most likely due to ESD, the card's control-chip has been fried. It could also be due to an over-voltage, such as a 5V on one of the card terminals for a longer period of time.

ESD is the reason for many unexplainable electronic failures, including your cell-phone suddenly gone dead, you only had it in your pocket (of your synthetic jacket) for 4 minutes.

I recommend everyone to watch these videos, the first is like a 'lightweight intro' (advertisement), but it's very educational anyway:

ESD Intro

The Shocking Truth (1 of 4) (follow its links; I'm only allowed to post 2 links in here)

| improve this answer | |

I had the same issue but solved it by using the settings on the second part of this page about ZAR – Real-time disk reader settings. In this case, this is what's recommended:

"Timeout" – set to 200 ms unless doing RAID recovery. For a RAID recovery, set to 500.
"Retry attempts" – set to 1 unless the analysis is unacceptably slow. To increase speed, set to 0.
"Avoid repeated retries" – enable.
"Skip factor" – set to 32, unless the analysis is unacceptably slow. To increase speed, gradually increase "Skip factor" until satisfactory speed is achieved.

I knew my card was fine. I could open it in the computer and browse files, use it in the camera, etc. I just removed the files off of it after loading them into my laptop. Then some water splashed on the laptop. So I wanted to recover the one day's worth of photos and videos on the card that I had just deleted. Zar is the only tool I found so far that said it will recover photo and video files for free and unlimited, but it marked all sectors of the card as bad, when that can't be true. Other programs found files but won't recover them for me because of their limits. .

Once the laptop's keyboard dries out in a few days I can maybe get the files, but I wanted them now to keep my vlog all in order.

Changing the setting fixed the issue.

| improve this answer | |
  • Luckily, you have been diligently using Win32DiskImager so you can just restore the .img file either back to that card or to a new one. – SDsolar May 13 '17 at 22:40
  • You might consider posting in the details of the settings you got from the linked website – user567048 May 14 '17 at 1:43

I have the same problem here on an ADATA 32GB card. Genuine, found in a batch marked "faulty".

I did determine that all the sectors are bad even ones used for geometry storage. This might have been malicious but the fix for some is just to nuke it! Managed to build a power supply and ended up using a DAC32 and then a 5642 vacuum tube to emit some low level X-rays <10keV which was just enough to reset the similar read only card and get it working again.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.