15

I have an ISO image of my backup solution's recovery cd. When I burn the image to a CD-ROM, I can boot from it in UEFI or normal mode without problems.

Unfortunately, this is no solution for my laptop, as it does not have an optical drive. Thus, I tried to create a bootable USB stick that can also boot in UEFI mode, but so far I have not been successful (note that the laptop has UEFI and boots Windows 7 in UEFI mode).

So my question is, if anyone knows how I can get said ISO on my USB stick so that it boots as if I would use a CD-ROM?

5
  • What process are you using to create the bootable USB stick.
    – Ramhound
    Nov 1 '12 at 13:57
  • I have searched for some tools to create bootable USB sticks (Unetbootin, Rufus, make_me_bootable among others). But either they weren't able to create a bootable USB stick at all, or it was only bootable in normal and not UEFI mode.
    – shiin
    Nov 1 '12 at 14:04
  • Related / dup: superuser.com/questions/531793/…
    – ripper234
    Apr 16 '13 at 7:47
  • The guys at eightforums has a good step by step ---> here
    – tekiwibird
    Aug 26 '13 at 4:14
  • Perhaps it would be simplier to change the bios from uefi to Compatibility Support Mode (CSM)
    – user284802
    Dec 26 '13 at 22:56
4

Please clarify: can you boot that CD in both BIOS and UEFI modes? E.g. does it have two boot records in boot menu or a mode switch knob?

Preparing a UEFI-bootable USB flash drive is actually way simpler compared to an ISO, at least has been so in my experiments: a FAT partition with EFI/BOOT/BOOTX64.EFI which knows what to do next compared to specially crafted El Torito boot floppy image with the same crap.

Maybe you'll need to extract that efiboot image, mount -o loop it and extract the contents into EFI/BOOT directory.

3

Rufus supports BIOS and UEFI systems.

You need to set the filesystem as FAT32. By default Rufus uses NTFS and that's not readable by UEFI.

2
  • This doesn't work. It says "0 devices found". See i.stack.imgur.com/5VVwV.png
    – Pacerier
    May 1 '15 at 16:36
  • Rufus may not give a FAT32 option if the downloaded ISO is > 4 GB. I tried using Rufus & discovered that the ISO which it downloads was 5 GB. It was above the 4 GB FAT32 OS threshold. I had to reformat a 32 GB FAT32 USB stick as exFat. Then I could copy the 5 GB ISO onto it. If Rufus only shows NTFS, check the file size to see if it's > 4 GB.
    – Clomp
    Jan 17 '21 at 21:00
1

You should be able to simply format the flash drive as FAT32 and copy the contents of the ISO to it.

I believe that you don't need any further steps.

2
  • unfortunately not; even if I make the partition active
    – shiin
    Nov 1 '12 at 14:16
  • Windows won't let files which are > 4 GB be copied over to a FAT32 drive, even when you have plenty of free space. The drive may need to be reformatted as exFat.
    – Clomp
    Jan 17 '21 at 21:02
1

I just put the full Eightforums guide here, but all the credits go there. Many guys here (SLaks and Michael Shigorin) proposed the idea, but neither offered the idea exact implementation steps as 8forums guys did.

Here they are:

  1. Insert USB-stick and open elevated command propmpt

  2. diskpart
    list disk
    

    Observe the list and pick the number your USB-stick was assigned, then select it via that number

    select disk #
    
  3. Create single FAT32 partition on it

    detail disk
    clean
    create partition primary
    format fs=fat32 quick
    active
    assign
    list volume
    exit
    
  4. Final step. Copy the contents of the boot ISO to the stick.

0
  1. Most UEFI systems will be able to boot only x64 boot media in UEFI mode as here
  2. With customized ISOs, it will always be experimental and may support one or the other.
  3. Normally, UEFI boot needs a FAT32 format drive or such partition on the boot drive. But FAT32 can only support files that are less than or equal to 4GB. So, the Isos, which are having files ( extracted ) larger than 4GB, has to be applied to the boot media with some tricks.
  4. SLaks way will be possible only as long as the biggest file (normally install.wim) is lesser or equal to 4GB because it uses single FAT32 partition on the boot drive.
  5. Rufus uses a single FAT32 partition when the biggest file is under or equal to 4GB otherwise, you will only have NTFS as an option with UEFI + GPT. That way, you will need to disable Secure Boot in the UEFI firmware to boot into the media. Once Installation or Repair is complete, you can again turn Secure Boot On, but Secure Boot disabling/enabling is not very straight forward in all UEFI firmware such as some Asus Motherboards

Methods: (assumes the largest file is less than 4 GB)

(A) SLaks way

  1. Download the required ISO : Win 8/8.1/10 / Win 7
  2. Extract the ISO to a folder with a good archiver, such as7zip / WinRAR
  3. Insert the pen drive & format it as FAT32
  4. Copy all the files from the extracted ISO folder to the root of the pen drive
  5. The drive is ready to boot from (will be bootable in both UEFI & MBR)

(While working with ISOs with .wim & .swm files, this way, they always booted in both UEFI & MBR)

(B) Rufus Way

  1. Insert the pen drive
  2. Launch Rufus & follow the below image and instructions:

Rufus: Biggest file 4GB

- *Drive will be formatted, so back up any important data on it*
  1. Select the pen drive in the Device menu
  2. Click SELECT, browse to the Win 7/8/8.1/10 iso and double click it
    • It will show under Boot selection (marked as blue in the Image)
  3. Choose Partition scheme as GPT & Target system as UEFI
  4. Press START
  5. Once it shows READY, it's done, and you can close Rufus

Methods: (assume largest file > 4GB)

Do you have a file(s) larger than 4GB?

When the largest file(s) is / are greater than 4GB,

SLaks way will prompt you with something like 'the file size is not suitable for ...'

Rufus will give you no option of FAT32 against UEFI + GPT, leaving only NTFS to go with!

(Obviously, these methods will also work when the largest file(s) is / are smaller or equal to 4GB!)

The ways:

(A) Rufus: Go with UEFI + GPT + NTFS & Disable Secure Boot to boot into the media!

(B) Change & Replace the .wim file to .esd file & use the SLaks way.

There are many ways to do that like DISM++

(But I won't suggest that because that process takes up a lot of resources. If your system is not powerful enough, It will substantially paralyze your system!)

(C) Split & replace .wim file to multiple .swm files which should be smaller than 4GB individually!

I found that only one file was over 4GB in the ISO which was install.wim. All other files & boot.wim was well under 4GB. So, we have to split & replace install.wim

We will use : wimlib-imagex

The general command is :

wimlib-imagex split --check windows.wim windows.swm 100

We want to split install.wim in 1200MB install.swm chunks. So, the general command for us :

wimlib-imagex split --check install.wim install.swm 1200

But.. we will need to tell path(s) for everything wherever needed.

For a practical eg.:

  1. Extract the windows iso to a folder with an archiver: 7zip / WinRAR

  2. Make 3 folders in the c: root i.e.: c:\New 1 , c:\New 2 & c:\New 3

  3. Extract the downloaded wimlib zip file to the root of the New 1 folder.

  4. In the extracted iso folder, navigate to Sources folder. Drag & drop .install.wim to New 2 folder.

  5. Open a command prompt.

  6. Copy, Paste & Run this command as it is (with quotes!):

"c:\New 1\wimlib-imagex" split --check "c:\New 2\install.wim" "c:\New 3\install.swm" 1200
  1. Wait for the things to finish.

  2. Exit command prompt.

  3. Your install.swm files are ready in c:\New 3

  4. Navigate to the extracted iso folder & Replace install.wim with install.swm files.

  5. Format the pen drive with FAT32.

  6. Drag & drop the Iso extracted folder ( in which we have replaced install.wim with install.swm files ), to the pen drive & let it finish.

It's done!

(This way the pen drive will be bootable into both UEFI & MBR)

8
  • 1
    1. When Rufus uses NTFS with UEFI + GPT, It still makes a small FAT32 partition ( along with an NTFS Partition! ) on the boot drive but one will need to disable Secure Boot in order to boot in that media as said above. 2. I appreciate, thank & request people here @SuperUser to keep on helping us with their fine tunings. Thanks & Regards. ... Nov 13 '19 at 14:58
  • 1
    Please use the correct markdown formatting for number and unnumbered lists, as well as for monospaced code. When you edit your post, at the far right of the formatting bar there will be a question mark icon... please click it to get help with how to use markdown (you can also see how it's implemented from the first edit I performed to the top of your answer).In its current form without markdown formatting, your answer is taxing to read, as it's severely muddled. Once markdown is applied, I'll remove my downvote.
    – JW0914
    Nov 15 '19 at 16:30
  • 1
    I have chosen above the chunk size of Install.swm files as 1200 MB. In case of a very big Install.wim, the chunk size can be maximized @ 4GB i.e. 4000 MB. Dec 1 '19 at 6:10
  • 1
    I am submitting this comment to nearly every one of your answers. We do not consider greetings, salutations, or signatures to be helpful. So please avoid using this in your answers in the future. Specifically with regards to this answer, even after numerous revisions, it had numerous grammatical mistakes. Please take a moment and use the appropriate tools to avoid that issue in the future. Contributions that have numerous grammatical mistakes often will result in a downvote.
    – Ramhound
    Dec 12 '19 at 10:33
  • 1
    I would like to add that Windows 7 Installation media does not cooperate with 'Install.esd' file. So, that will not be the option for windows 7, unless installation files are borrowed from windows 8 or 10 installation media. Though the untouched MSDN windows 7 sp1 32 / 64 ISOs have 'Install.wim' file less than 4GB in size, that may exceed with updates integration! May 6 '21 at 7:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.