I just installed matlab on my computer, seemingly successfully, but I've been trying to run a program, and I'm getting the following error:

>> reproduceResults
Warning: Directory already exists. 
> In reproduceResults at 14 
Processing ./data/baby.mp4
Error using VideoReader/init (line 429)
The file requires the following codec(s) to be installed on your system:

Error in VideoReader (line 132)

Error in amplify_spatial_lpyr_temporal_iir (line 31)
    vid = VideoReader(vidFile);

Error in reproduceResults (line 20)
amplify_spatial_lpyr_temporal_iir(inFile, resultsDir, 10, 16, 0.4, 0.05, 0.1);


For reference, the code that I'm trying to run is here: http://people.csail.mit.edu/mrub/vidmag/#code

I'm running reproduceResults.m, after downloading all of the video files that they provided.

Any help would be appreciated!

I can't find any answers on google that work. The one that I've tried is this: http://memyselfandcomputer.blogspot.com/2011/01/matlab-2010-videox-h264-error-on-ubuntu.html

It doesn't seem to change anything though. Is there a way to get a more verbose output to help me debug/search better?

  • I'm asked to log in when I click the last link in your post, by the way, so I don't know what you've tried already, but have you tried installing the x264 package? It might be named something slightly different in Ubuntu, but run apt-cache search x264 and I can try to advise you. – Ricardo Altamirano Mar 3 '13 at 22:49

A little late but I also ran into the same issue. One fix is to install the codecs via apt-get:

sudo apt-get -y install gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse

This fixed it for me.

  • 2
    I had to remove the last package: sudo apt-get -y install gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly ` – auraham Oct 5 '13 at 5:07
  • I had success on a Matlab Amazon EC2 instance with even fewer packages: sudo apt-get -y install gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad gstreamer0.10-plugins-ugly – Daniel Golden Apr 15 '14 at 22:33
  • This should be marked as the answer – twerdster Jul 19 '15 at 16:56

Here is a thread that suggests multiple solutions, hopefully it contains the right one for you: http://ubuntuforums.org/showthread.php?t=775943

sudo add-apt-repository ppa:mc3man/trusty-media
sudo apt-get update
sudo apt-get install gstreamer0.10-ffmpeg

Add this ppa for gstreamer0.10-ffmpeg on 14.04, had the same problem and fixed for me now.

  • 1
    I'd note that it looks like those repositories are specific to 14.04 (which this question pre-dates). I'm also curious to what this offers over the default repos – Journeyman Geek May 9 '14 at 10:19
  • For 14.04, this ppa is needed to install gstreamer0.10-ffmpeg - the package in the default repo cannot currently be installed on 14.04. – funkotron May 27 '14 at 12:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.