I installed Windows Phone 8 SDK, and tried setting up the emulator. But it complained about my system's virtualization setting is not enabled.

I have installed Hyper-V from the "Add Programs and Features". When I go to my BIOS setting, I don't see such an option from where I can turn on the virutalization setting.

My motherboard is ASUS M5A88. Do I need to upgrade my BIOS?

Update: As per the suggestion, I updated the BIOS, and have turned on that setting, but still, Visual Studio fails to start the Emulator with this error. The older BIOS didn't have that setting though.

enter image description here

Update: I found the setting under "Advanced -> CPU Configuration". "Intel Virtualization Technology" is not there, I guess, because, it's for an AMD processor.

Still, no luck. I did a check by downloading a small utility, which checks if Virtualization is suuported on my system, and it said my system supports Virtualization.

My processor is an AMD-FX8150, if that matters here.

From the system requirements page of the dev site, I tried to CoreInfo tool, and that tool also says my system supports Hardware-assisted virtualization.

enter image description here

I have also enabled DEP for all programs from the Control panel.

Solved: After enabling virtualisation from BIOS, I had to re-install the Hyper-V packages from the "Turn Windows features on or off" program, re-start my system, and it started working.


According to this post, you need to have the latest versions of the BIOS to work with Hyper-V and enable to the Virtualization:

The older versions of bios didn't have that option, but it was enabled by default. The latest releases 1202, 1305 versions, have the option to enable or disable, the virtualization feature.

There are two places that this could potentially be:

  1. This SU Post suggests it's found under "Intel Virtualization Technology"
  2. This SU Post suggests the option is under "Secure Virtual Machine Mode" in Advanced-->CPU Configuration

I would check for both.

Since Hyper-V uses a Hypervisor this is necessary in order to enable the Win Phone 8 emulator.

  • I updated my BIOS, and enabled the setting. But, still, VS fails to start the emulator with the same message. Nov 1 '12 at 18:15
  • Updated my question. Nov 1 '12 at 18:18

On your motherboard, you need to enable the setting called "Secure Virtual Machine Mode" in your BIOS. This enables the virtualization technology (AMD-V) on your CPU, which Hyper-V and the Windows Phone SDK require.


This is works for me:

  1. Disable Hyper-V in control panel
  2. Restart
  3. Enable Hyper-V again in control panel
  4. Restart again
  5. Open Visual Studio and try again

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.