I am trying to connect my Microsoft Surface tablet to an ad-hoc network that I setup on my Windows-7 desktop machine. The Surface machine can see and connect to other hotspots, but it cannot see the ad-hoc network, whereas a second Windows-7 laptop sitting next to the Surface machine can see it.

What would cause the ad-hoc network to be visible to Windows 7 but not to Surface?

Additional data:

Windows-7 is on domain, but Surface is not.

  • Have you double checked that the wifi on the Surface is turned on. – Windos Nov 1 '12 at 22:56
  • Good question. Yes. I will add that to the question. – GaTechThomas Nov 1 '12 at 22:57
  • Can you see non ad-hoc networks? – Windos Nov 1 '12 at 22:57
  • Yes, I can see non ad-hoc networks. – GaTechThomas Nov 1 '12 at 22:59
  • I'm now thinking that it has to do with domain / non-domain machines. The Win7 machine is on the domain but Surface is not. – GaTechThomas Nov 1 '12 at 23:31

Not only Windows RT can't connect to an ad-hoc hot-spot, but it seems even Windows 8 Pro can't do it (and provide Internet access). I have Joikuspot on a Nokia Symbian phone. This creates an ad-hoc hotspot, which my household's Win7 PCs can connect to with no problem. My Win8 PC can see the hotspot and connect to it, but can't access the Internet. It claims that the connectivity is "limited" and it can't gain an IP address.

In answer to the OP, the solution would be to enable the virtual hosted network on the Windows 7 machine instead of an ad-hoc connection. This simulates a full router in infrastructure mode. You need to use the netsh command in an admin command prompt. Search "netsh hostednetwork", and you'll get the answer.

Surface do not support ad hoc networking see this link http://windows.microsoft.com/en-US/windows-8/whats-new-in-networking

i have tried this too and contacted the support.

Surface RT doesn't support ad hoc networks. See the link in Mario's answer. What Surface does support is a connetion to a virtual hotspot. The best instructions I could find are here: http://www.mypersonalgetaway.com/tag/nokia-lumia-800/ I already had the same problems with my Lumia. BTW if it doesnt work right away try to disable bluetooth on your laptop. That did the trick for me. Hope I could help.

Verify that the ad-hoc network is functioning by using a third, unrelated device to connect to it, such as yet another Windows computer, a Linux or Mac, or another mobile device.

  • Yeah, unfortunately someone broke into my house and stole all the laptops that I could do that with. But I will certainly give it a try when I can. – GaTechThomas Nov 3 '12 at 2:27

You surely CAN connect Surface Pro to ad-hoc network. The only problem is that Surface does not detect ad-hoc networks automatically. Instruction to manually connect to network is quite simple:

  1. Go to "Network and sharing center"
  2. Select an option to "Setup up a new connection or network"
  3. Select "Manually connect to a wireless network"
  4. Fill the form.
  5. Now you can see your ad-hoc in the list of wireless networks.

This instruction won't help in case of Surface RT

  • 1
    the question is for windows rt, and clearly your solution is for pro, so this does not help the user – Shekhar Jul 30 '13 at 14:33

Your Answer


By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.