6

I noticed on my MacBook Pro from 2011 with Windows 8 that the fans start spinning when I leave my laptop idle for a while.

I figured that it is Windows Defender which seems to be running. Is it possible to disable this background scanning - or whatever it is doing?

I still want to have real-time protection enabled; I just do not need any background scan to run when I'm not using the machine.

  • 1
    Have you ACTUALLY confirmed Windows Defender is doing a system scan? – Ramhound Nov 2 '12 at 10:52
  • No. Only that it is the Windows Defender process which is using the CPU. I have disabled the scheduled scans though. – kfuglsang Nov 2 '12 at 12:30
4

Disabling \Microsoft\Windows Defender\MpIdleTask in the task scheduler will prevent autoscans when your computer is idle.

  • For those wondering, it's been renamed to "Windows Defender Scheduled Scan" now. Check the "last run time" date/time to confirm it's the right one – twig Feb 12 '19 at 12:57
2
  1. Go to search on the charms bar.
  2. Lookup Windows Defender.
  3. Click on the settings tab.
  4. Click on real time protection and uncheck "Turn on real time protection".

Or if you want to turn it off completely go to Administrator and uncheck "Turn on Windows Defender"

  • I just added a comment about real-time protection to my question. – kfuglsang Nov 2 '12 at 9:34
  • This was the only solution which worked for me - to disable defender competely – John Little Apr 2 '15 at 13:10
  • I've run into this issue when trying install Ruby for Windows. "Turn off real time protection" didn't work for me, I had to "Turn off Windows Defender" for a while. – Andre Figueiredo Apr 14 '15 at 18:58
1

You can add Windows Defender to the exclusion list for RT checks. It seems that it scans itself whenever it runs.

(Windows 8.1) Go to Control Panel > Windows Defender, click on the 'Settings' tab, browse to C:\Program Files\Windows Defender and select MsMpEng.exe, Hit 'Add' and 'Save changes' and that should help quite a lot.

It should be noted that now your computer will be vulnerable to any exploit that uses that file, but that beats being vulnerable to any infected file should you turn it off or exclude your entire C:\ drive as somebody else suggests.

  • 1
    This did not make any difference to defender using a constant 100% of the cpu for me. – John Little Apr 2 '15 at 13:10
  • Can't help you further John, sorry. I gave up with Windows 8.1 and installed Linux Mint. Haven't looked back since. – Charles Goodwin Apr 2 '15 at 21:53
0

I have the issue with MSE and Defender. The only solution is to disable the Defender and use a 3rd party tool. NOD32 v6 (RC) works for me fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.