I have just upgraded Windows on a Dell PC from from 7 to 8. All went swimmingly until I tried to re-install graphics drivers for a GeForce GT 630. After the NVidia setup program completed, it requested a restart - I obliged, and now it goes to a black screen after the windows loading animation. It's odd actually - the screen blinks as if only receiving power every three seconds or so, for just a second (when it just shows a black screen), before going actually dead again.

How can I fix this? Or at least get into Windows in Safe Mode?

Single HDMI cable has been plugged, unplugged, and re-plugged to no avail. Its a 64-bit machine, running a 64 bit Windows 8 upgrade where nothing was kept from an old 64-bit Windows 7 version.


So somehow, the wrong driver is installed (perhaps the 32bit version or the wrong model number?) and you need to see the screen to restore things. Probably the best way is to boot in to safe mode, which uses default Microsoft VGA drivers. From there, you can attempt to use "system restore" to go back to a restore point before you installed the driver (if there was a restore point taken, if you are lucky) or attempt to load another driver. Apparently getting into windows safe mode has changed (formerly just bash F8 before windows starts up). Here's one page of info a getting in to safe mode in windows 8.

  • Yeah, found the same article myself, which says holding shift and bashing the F8 key is the new way to go - sometimes. Hasn't worked for me yet! Am currently trying to boot off a Win7 iso on a USB... – Eamonn Nov 3 '12 at 13:55
  • 1
    Eventually got into Safe Mode by changing the BIOS boot order to Removeable, Removeable, Removeable - and not attaching a Removeable drive. Bananas! – Eamonn Nov 3 '12 at 16:54
  • Interesting. +1 for the update. – jdh Nov 3 '12 at 17:39
  • Accepting as an answer - Got into Safe Mode, rolled back to a restore point, managed to dl proper drivers, installed, rebooted, re-ordered BIOS boot order, success! – Eamonn Nov 4 '12 at 11:57

I was facing the same problem after re-installing the drivers after the upgrade from windows 7 to windows 8.However I had resolved the problem after installing the latest beta driver released(AMD 6770).I think the same problem is being faced by you.Follow the following steps.

1.Remove the drivers by going to device manager and selecting your device.

2.Download the latest driver saying windows 8 and correct architecture(x64 or X36).

3.Install the drivers and restart the system

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.