-1

I went into a man page by typing man man and then typing /firewire but I keep getting a message that says 'pattern not found'. I have tried every possible solution

If the way I'm doing things is wrong, by searching within a man page, please could you point me to the correct way.

  • Why do expect to find the string "firewire" in the man man page? Are you trying to find some man page relating to FireWire? Maybe you're looking for apropos. – Araxia Nov 2 '12 at 17:54
  • iim trying to find the some man page relating to firewire – Zaki Ghanem Nov 2 '12 at 17:57
1

Try searching for 1394 in the man.

1

For general information try Wikipedia article on Firewire (also known by its standard name IEEE 1394), or your favourite search engine.

man man displays manual page for the man program itself, and the /firewire causes the pager (the program that displays the manual page) to search for the word in the manual - which it doesn't contain. When you want manual on something else, call it with appropriate topic, e.g. man sh to get manual for the shell (system command line interface). You can also try using the apropos utility to search headings of man pages for a specific term.

  • I've tried many different varieties, man -k firewire, man firewire, but having no luck at all to bring up the term firewire within a man page. – Zaki Ghanem Nov 2 '12 at 18:00
  • Very likely because you don't have the manpage of that name installed. If you check the ubuntu manpages you may notice, that it is provided by the freebsd-manpages package. If you install it, you should be able to read it off-line with man, but note that since it comes from FreeBSD not all information therein may be correct for Linux. For general terms like Firewire, USB, SATA, wikipedia (or a search engine) really is a better source to start with (if you want to get some insight). – peterph Nov 2 '12 at 18:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy