How can I use Gmail (in Chrome) as the default email handler in Windows 8?

I used to use GmailNotifier in Windows 7, but that doesn't seem to work anymore. Clicking on a mailto: link simply opens Chrome with a blank page.

I am not interested in using the Mail app built into Windows 8.

up vote 20 down vote accepted

Open Gmail in Chrome. Then see this. Click on the eye in the address bar.

enter image description here

  • 1
    I tried that, but it doesn't work, even when clicking a mailto link within Chrome :( – Leftium Dec 28 '12 at 2:29
  • @Leftium Can you see the options of screenshot? Have you selected Use Gmail? And, what's the version of your Chrome? – Apple II Feb 1 '13 at 20:01
  • hmmm.. this seems to work, now. I'm not sure what changed since the last time I tried it~ – Leftium Mar 18 '13 at 5:12
  • Ah that's great! – pratnala Mar 18 '13 at 10:48
  • 1
    @Entrodus Done. Added the additional instruction – pratnala Apr 10 '14 at 10:11
  1. Close Chrome
  2. Open C:\Users\<your username>\AppData\Local\Google\Chrome\User Data\Local State with Notepad (or, any other text editor).
  3. Locate "javascript": true, in protocol_handler section of the file, replace true with false and save the file.
    Chrome State Settings
  4. Launch Chrome, visit Gmail and Sign in.
  5. In address bar of same tab, type/paste this & hit enter: javascript:navigator.registerProtocolHandler("mailto", "https://mail.google.com/mail/?extsrc=mailto&url=%s", "Gmail");
  6. [Optional] Close Chrome & revert back your changes in Local State file.
  7. Open Default Programs.
    Search for Default Programs
  8. Click Associate a file type or protocol with a program.
    Default Programs dialogue
  9. Select MAILTO and then click Change program... button.
    Set Associations
  10. Choose Google Chrome from the list.

Done!

Follow the steps after installation of Gmail Client enter image description here enter image description here enter image description here

Change your Default Client to Gmail..

Hope this Helps...

  • 4
    There is no Gmail option! – Leftium Nov 4 '12 at 8:32
  • @Leftium see my answer – pratnala Dec 27 '12 at 10:41

See the below link. It expands upon Sant14's answer by first having you create the necessary entry that would then show up in your 'Default Programs' > 'Programs' list.

http://www.groovypost.com/howto/change-windows-8-default-email-client/

I found an easier solution. The link below installs an applet which gives you the option as a check box, and you don't have to use Chrome. I'm using Firefox because I have some sort of virus on Chrome that hijacks clicks and sends me to advertisements.

http://toolbar.google.com/gmail-helper/notifier_windows.html

  • This is no longer supported by google. – Lenne Jul 17 '16 at 21:00

protected by Community Mar 1 '14 at 21:03

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.