9

I'm trying to export a LibreOffice document to PDF and have my hyperlinks open in a browser, but no matter what I do it seems as though they try to open them locally (i.e in my file system). I don't want to send this out to people and have it not take them to the websites I intend it to link to.

The sort of link I have is just http://www.firebox.com and I can ctrl-click them to open in the browser when it's jsut a .doc. Once I've exported them to pdfs clicking on them opens a little window that says 'Transfering' and then it opens up gedit with a blank file and a file named .

Currently I've got

  • LibreOffice 3.5.4.2
  • Okular 0.14.3
  • Ubuntu 12.04 LTS
  • Chrome & Firefox (latest versions, Chrome is default)

Is it my PDF viewer, or the options I'm selecting in LibreOffice?

  • Can you give an example of one of the actual links you are embedding, and clarify what you mean by it tries to open it in your local file system? Are these hyperlinks prefixed with a HTTP:// or alike? – Ƭᴇcʜιᴇ007 Nov 4 '12 at 18:49
  • @techie007 updated with an edit – Pureferret Nov 4 '12 at 19:29
  • 1
    Have same problem. I wish that was answered! – David Csonka Mar 28 '13 at 21:24
6

When I choose "Export as PDF" from the File menu I get a window of PDF Options with the "General" tab selected by default. I will assume for the sake of this answer that this is the same for you as well. If you look toward the right-hand end of the tab bar in that PDF Options window (second to last option just to the left of "Security") there should be a tab labeled "Links".

PDF Options Window

It strikes me that some of these options are likely to be helpful. I found the option which I have selected "Open with PDF reader application" useful for linking to other PDF documents on my filesystem, but I suspect the option which you are wanting is the one just below that "Open with Internet browser". When I test this with my own system (Linux Mint Debian Edition with LibreOffice) it works as expected, opening the clicked link in Firefox (my default web browser).

Also useful to be aware of is that if you have the "Selection" tool selected in the Okular toolbar then links are NOT clickable, as the assumption here appears to be that you are intending to select text for copy/paste operations. To ensure that your links are actively clickable be sure that you are in "Browse" mode (just to the left of the "Zoom" button on a standard Okular default toolbar).

I hope this works for you as described. :)

  • 2
    Thank you, for me it was a problem of "Selection" tool selected in the Okular toolbar, not a problem related to pdf export... – Michele Jan 25 '17 at 10:51
0

LibreOffice has export to pdf ability, and it can preserve URLs. Go to File -> Export as PDF or use pdf export button on the toolbar to do so.

  • 2
    This is what I've done. It doesn't work. 'I'm trying to export a LibreOffice document to PDF and have my hyperlinks open in a browser, but no matter what I do it seems as though they try to open them locally' – Pureferret Nov 4 '12 at 15:43
0

Same problem here: https://forum.openoffice.org/en/forum/viewtopic.php?p=376045

I had the same problem. I update LibreOffice version, and now the external hyper links are interpreted as local relative links even in Writer, without exporting to PDF.

It happens with an URL that contains a colon. If I remove the colon, it works fine.

http://foo.example.com:80?bar=41118102&xyz=1 is wrongly linked to file://http://foo.example...

http://foo.example.com/?bar=41118102&xyz=1 works fine

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.