I'm running Windows 8 and am unable to connect to my home wireless network. I've tried restarting the router, patching the drivers to the next version, patching the drivers to the last version, running windows update and patching the chipset drivers to the latest version.

So far nothing has worked. My computer can get on the internet via USB tethering on my phone or an open Wi-Fi connection, but it is unable to connect to my home WPA2 AES secured wireless network. It sees the network, attempts to connect, gets a limited connection and then drops the connection. All the other wireless devices in my household have no problems.

I have the new Dell XPS 12, running Windows 8 using an Intel Centrino Advanced-N 6235 wireless adapter.

I've refreshed Windows twice now to try different driver configurations. I've tried uninstalling all the Dell software, I've tried uninstalling all the Intel software and reinstalling just the drivers. I've tried turning switching the ability for the Wireless driver to turn the computer off or on. I've tried setting up the connection manually from desktop mode. I've tried switching it on and off using the wireless button on the keyboard and in the software.

So far nothing has allowed me to connect to the secured network. It just keeps getting a limited connection, dropping the connection and retrying.

EDIT: In addition to switching off some of the weird WiFi connection managers, I also had to switch the channel of the WiFi itself in order to connect.

  • Have you checked any mac filtering for the device was set. Also connect your laptop to lan and then restore router to factory settings.. then retry to connect using wifi.. – Anvesh Vejandla Nov 5 '12 at 5:28

I had a similar issue with my Acer laptop a month back.

Basically it was whatever helpful 'apps' comes with the wireless driver to give you a connection manager.

My one was called 'easyconnect'. I had to prevent it from starting up using Task Manager.

Rebooted and now it works great.

Check your Windows Desktop task tray (near the clock) for little icons for 3rd party tools that help with connections, make sure they are all GONE when the system first boots up. and then the normal windows tools will connect fine.


If other devices are properly connecting to your wireless network, that means that the router is good, and there's a high probability that the issue is with the computer.

You can test first if your computer is getting a valid IP address. Run Command Prompt (Administrator), then type ipconfig to check the IPv4 address. If it's not valid, release and renew the IP address via Command Prompt again, then reboot the computer.

If you're getting valid IP address, you can check Device Manager for any errors on the Driver, if driver is good, proceed in checking your Network Settings, IPv4 must be checked and IPv6 should be unchecked. If you'll make changes on the Network Settings window, don't forget to reboot the computer. If still you'll get the same error (Limited Connection / Access), try to run the netshell commands, then reboot the computer.

If you'll still get the same result, you need to contact Dell to check the unit.


One thing that can be tried is to set the wireless security settings on your router to WPA TKIP and then give it a try. If TKIP is not an option it may be because your router is set to 802.11n only you may want to change it to 802.11bgn or 802.11gn to get the tkip option. I hope this helps.


Do you have any virtual machines installed? If so remove and re-add the network bridge. This may need to be done after installing Windows 8 update.


I hate to point to my shortcomings but... Similar problem

The message on Windows 8 was the generic "Limited" access message. All my other non-windows 8 devices could connect fine.

After validating the Windows 8 Laptop could get WiFi connection on another device, I focused on the router.

Turns out, when I was setting up the laptop initially I used incorrect case for one or more characters in the WiFi password. You don't get a password, error you get the Generic "Limited" access error.

Click on the connection, tell windows to forget it, and reconnect with the correct password.

protected by Community Jan 12 '14 at 2:09

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.