4

Right Clicking Ubuntu Gave me the option of running it as admin

I noticed that on Windows 8's Start screen, I could right click a Windows legacy program (A program which runs on Windows XP, Vista and 7), and I could run it as Administrator.

Right Clicking Bubble star with no option of running it as admin

However, whenever I clicked on a Windows 8 Modern UI or a Metro app, I didn't have that option.

So here are my questions:-

  1. Why can't I run the Modern UI apps as an Administrator?
  2. Does it make any difference as far as security is concerned?
  • 3
    Modern apps are sandboxed. – Sathyajith Bhat Nov 5 '12 at 11:16
  • 4
    This is by design. These applications should not need to be ran as administrators since they cannot do anything that requires it. – Ramhound Nov 5 '12 at 11:29
4

If you kill explorer.exe process and run it as administrator, here is the error message that Windows will give you:

An administrator access is only required in Windows when an app wants to access system files and folders.

Windows Store apps are sandboxed where they can't get access to system files or raw file system access. Windows Store apps can only access the libraries and removable media by itself and if it wants to access any other file, the user has to select it through a file-open-picker to give the app permission to do it.

2

good question, and this further highlights the confusion between 'legacy' apps and 'Windows 8 Store' apps.

Windows 8 Store apps run under the current user only, and have no need to run as an administrator as, a bit like on an iPad, they run in their own 'sandbox' / environment, separate from the rest of the entire system.

  • and how can I run Microsoft Edge being from the administrator account or without being sandboxed? – skan Aug 18 '15 at 17:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.