I have an NTFS filesystem on an external hard drive in an enclosure (SSD). I use this for web development on two Windows systems (A, laptop and B, desktop). I assigned the drive letter as G: because I wanted absolute paths for PHP to be consistent.

The enclosure was giving me trouble so I switched to another (went from Ineo to Sabrent). This new enclosure uses a double cable, one for USB 3 and the other, presumably, for power. I plug in both for the laptop, and the same for the desktop, except the desktop USB card actually has power too. I've tried this drive/enclosure with and without the power cable portion from the external drive. Doesn't seem to matter.

I should add that this drive with both computers USB 3 ports has worked in the past. The new enclosure mixed with the desktop system seems to be the issue. Also, I can plug the drive/enclosure into a standard USB 2 port and it seems to work. I have a 6 foot USB 3 extension cable running from the USB 3 card on the desktop to my desk, in which I'm plugging the SSD/enclosure with its cable.

The drive is recognized on one Windows 7 system (A) just fine but then when I plug it in to another (B), Windows tries to tell me to reformat the drive to use it.

I then noticed that it was assigning the drive a letter H when doing this because there were already partitions taking up, C, D, E, F and G. I went back in to the system that runs the drive without problems (A) and switched the drive letter to X, thinking this would keep it clear of everything. My thinking is that I can go in and modify PHP configuration settings gain, but with X instead of G. If this works, I'm OK with changing to X this time.

Now the same problem occurs. The system that didn't run it correctly (B) still is not running it correctly. Still assigning it letter H.

I'm looking for a way to reset this connection or otherwise get it to work. I have tried reinstalling the drivers to no avail. I suppose I do not have to manually set drive letters, but it's nice to have the consistency.

Has anyone had this kind of problem? I suppose it could be that the new enclosure and cable aren't compatible with the USB 3 card on the desktop system. But I really would like to run it at the higher speeds on this system.

Thanks in advance.


I think I have found another clue. When I plug the drive, with its own cable, directly into the USB 3 card on the desktop, it runs as it should, with assigned letter, X. So now it seems the extension cable I was using is the culprit. Is it possible that the power just isn't enough when going through the cable?

  • What shows up in the Disk Manager? – David Schwartz Nov 5 '12 at 16:28
  • Yah, good question: when the problem is occurring, the disk manager locks up on computer B. Like it cannot load data when the drive is in this state. – nicorellius Nov 5 '12 at 17:39

It turned out that the USB 3 extension cable I've been using cannot deliver the needed power. Not sure why that is, but it seems the cable wasn't designed for power as well as signal. I actually spoke to the manufacturer and despite the technician telling me the cable is rated to deliver over an amp, I tested it and it doesn't.

So what I did was just plug the drive straight into the USB 3 card installed through PCIe and it works fine. As X: it also works fine in the USB 3 port on my laptop.

I think I might get another USB 3 cable to see if I can get it to work.

Thanks for the help.


I've seen this before. If drives are trying for the same drive letter it'll just take the newest drive and won't even show the older one. Now for me this has always been mapped drives over a network connection, so I just disconnect the drive (ie: H:) and then I change the drive letter of the external drive out of that range. If the newer drive H: is a physical drive you'll probably be quicker to just disconnect it and deal with switching the external drive to X: via disk management and then reconnecting the drive.


Just to add to Daniel's explanation for the less wise who might come across this problem, her's how to use Disk Management:

  • Right click on the Computer icon on your desktop. Left click on Management.
  • Then left click on Disk Management under Storage.
  • The disk you are having trouble with will have no letter assigned, whether through a poor cable or whatever. Right click on the box that contains the drive (not the box to the left that says disk 3 or another number).
  • Click on Change Drive Letter and Paths.... A box will appear and then click on Add.
  • Choose the letter you want -- it will automatically assign the first available letter, but you may want to use another in case of conflict.

Plug and play hard drives are not all they are cracked up to be. I'm thinking of adding another enormous hard drive into my enclosure rather than having loads of extra drives working through USB ports.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.