I have an odd error that doesn't seem to fit in with any of the other odd Windows 7 x64 USB errors that have been kicked up on Google. Here we go:

  1. Uninstalled Tortoise SVN and clicked restart computer. My machine had been up for around 28 days
  2. On reboot my mouse and keyboard failed to work anymore, couldn't log in. Tried every USB port I have on my Dell 390 and the ports on my Dell 19's, nothing worked. They had power but Windows would not respond when I manipulated the keyboard/mouse.
  3. Rebooted my computer and pressed F2 to get into bios, my keyboard is working fine in bios. Keyboard and mouse work fine on other computers when using USB.
  4. Found adapters for keyboard and mouse to convert from USB to PS/2 ports, works fine. I'm actually typing this question on the same keyboard, same computer, just using PS/2 ports for my mouse and keyboard.

It appears to be a Windows 7 x64 issue. Other things I have tried:

  1. Multiple other mice and keyboards, iphone, all with no luck. Each one gets power, but Windows never tries to install drivers or sees that they are connected.
  2. Uninstall and reinstall all USB drivers. Drives uninstall and reinstall fine and report no errors in Control Panel.
  3. In Power Management I disallow Windows from turning off USB ports to save power
  4. Installed the latest nVidia drivers for my graphics card, no change.

Anyplace else I can look/try? Thanks!

  • 2
    It could be a Motherboard/USB port issue as well, it's not necessarily Windows 7 x64. I have a similar issue in Win XP here at work where my front USB has power, but Windows seems to ignore that anything is plugged in. The back USB ports work fine though. – Will Eddins Oct 2 '09 at 17:58
  • I'm thinking though if it truly was the MB the keyboard on USB wouldn't work in the bios... – ben Oct 2 '09 at 19:34

This is one of those lessons in, 'it could be anything'...turns out it was the MB. Swapped out hard drive into another identical Dell computer, booted it up and all of my USB devices started working fine.

To recap

  1. USB keyboard worked in BIOS, failed in Windows
  2. All devices had power
  3. Control panel reported all USB ports were working fine, yet no matter what you plugged in nothing would work.

I've never had a computer die in that particular fashion. Thanks Guard for suggesting to look at the MB a little more closely.


I have the same problem with power but not recognizing. I recently had a USB port get damaged by a cord being pulled straight down on something that was plugged in and all of the contact pins got bent to hell, then I had everything on that font panel fail, but still brief power when I plugged something in.

Mouse and keyboard were still working so I tried a USB drive in the back panel, same thing. So I unplugged my keyboard which was working and plugged it back in to same port, not working.

So I went to device manager and reinstalled USB ports. Now some of the front ones work but my keyboard and USB drive wont work on any, but work fine on other computers.


Before you dismiss this as a motherboard problem you may want to try another operating system on the target computer. Two days ago my video card seems to have died (artifacts and blue screens constantly on any pc it is placed in) and on its way out or by the same act of god/code my windows 7 64x professional has stop recognizing any USB device unless it is plugged into one, and only one usb port. If two devices are in at the same time, or one device is plugged into any other port it will send power but ignore the device.

Upon booting into my old vista partition everything is working correctly in place. There are no problems, yet a simple boot back into the windows 7 o.s. reveals once again all but one usb port is dead.

This may be unrelated to your problem but in my google searches your situation most closely resembles mine. I am hoping for a fix and will post back if I find one as I do not want to have to buy a new motherboard AND video card.

Best Luck


Yet again, same problem, same experience. Just built a new box. However in my case I've noticed that switching the keyboard and mouse from one port to another and then back to the SAME port that didn't work initially, somehow solves the issue.

Keyboard works perfectly in BIOS.

  • welcome to Super User! thanks for sharing your experience. does your workaround last after a reboot? completely solved? or do you have to do the musical-ports-dance every boot? (one suggests a driver problem. tho i'm not entirely sure which one.) – quack quixote Apr 23 '10 at 12:35

I saw similar behavior with mobile internet devices - for certain modes of failure, Windows effectively "blacklists" a device upon connection and treats the device as malfunctioning - this blacklisting is by hardware ID and connected port - I think but am not certain that this happens if it connects and then disconnects too quickly (possibly repeatedly) during initialization.

The fix we found was to delete all the USB root hubs from device manager, and reboot, causing Windows to forget about USB devices and try to reinitialize them all on the reboot. Be careful if you rely on a biometric sensor or smartcard to log in as sometimes these devices and mass storage devices won't reinitialize until after you log in to Windows. You'll need to pay attention to which USB root hubs service which devices, and avoid the ones serving authentication hardware if this is the case.

Edit: Also check for a USB filter driver from the chipset, motherboard, or PC manufacturer - some USB controllers fire off spurious connect/disconnect events that can cause devices to appear and disappear rapidly, which can manifest itself as hesitation, brief periods where a device simply doesn't work, disconnect/connect sound effects playing for no apparent reason, and/or windows blacklisting devices as malfunctioning on connect or after they have been used for a while


Here's the pro and easy fix for future people with the same problem:

Disconnect your computer from any and all power sources (so for towers, turn off and unplug your power source, for laptops, turn off, unplug, and take out your battery for a good 30 seconds)

Your USB port devices should be working properly now. Flipping usb microprocessors right?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.