I have been searching someone else having the same issue but I couldn't find any. Here is my problem:

I'm using Windows 8 Pro with Media Center. File search screen does not close itself after I make a file search within start screen. It stuck on that screen. I can't go back to desktop, therefore, task manager is inaccessible. Only way to get out of it is to sign out. It also looks like non-operational. It doesn't give me any result at all. It's just a blank screen with "Files" title. It used to work perfectly.

Things I have done before coming here:

  1. Safe mode minimal boot to ensure no other 3rd party software interferes.
  2. sfc haven't found any inconsistencies.
  3. Search index has been rebuild.
  4. Normal boot with all 3rd party services and start-up items disabled.
  5. System restore to a date that I know this feature was functional.

And by the way, I have installed all updates released so far.

I strongly used file search via start menu back in Windows 7. This is an absolute game changer for me. I'm curious what causes this. I'll do a "system refresh" if I can't fix this. I'm working on it, I'll keep this thread updated should I find any fix.

First update: I just discovered that file search screen gets stuck if it's invoked by typing query directly in start screen. It doesn't get stuck if it's invoked from win + x menu. I was able to "escape" from stuck screen with invoking it again by win + x menu. After rebuilding search index again, search suggestions started to appear again but still there is no file search functionality.

Second update: "Results for" expression appears only for a second near to "Files" title when search is initialized.

Third update: As a last resort, I finally tried to do a "System Refresh" which has also failed to refresh by giving an error after waiting almost 20 minutes at 99%. (Seriously?) After cold boot it began to undo changes. After changes were reverted, I boot the machine without doing anything further and bingo! Search began acting normal again. This is a totally weird solution. It obviously fixed certain system files during failed refresh, and kept those changes untouched because they were supposed to be that way at the first place. I'll keep this thread alive should anyone comes with a more logical explanation.

Forth update: After a windows update, search functionality again stopped responding. It happened after a system update for the first time. Now I have a pretty good suspicion about system update, though I have no solid proof of its involvement with this problem.

  • From what I read so far on the Web, the type-to-search feature may not work for searching files. Probably it has been designed that way. Thus, you will have to use the win + x menu (as you mentioned) or WINKEY + F. – Mamta D Nov 7 '12 at 8:20
  • It's been working before for file search as I mentioned at the end of second paragraph. You only need to select Files from right after you type the search term. I believe problem is caused by search functionality itself. No matter how you trigger search, it doesn't work. I mentioned about non-functionality at the end of first update. Thank you for your comment, I hope this thread won't be lost. – baturayd Nov 7 '12 at 11:15
  • Oh ok. Did you see the related questions that pop up on the right of this page? Perhaps some other question's answer has information that throws light on this? Do try. – Mamta D Nov 7 '12 at 12:41
  • Yep. I checked some of them. There are suggestions mostly about rebuilding search index, including different locations in index, etc. I couldn't see anything directly related to this getting stuck issue. – baturayd Nov 7 '12 at 17:42
  • 2
    @baturayd, I tried it again, and it seems you need to have "Always on top" turned on in the Task Manager options. If you do that, then Task Manager will appear on top of Metro. – dangph Dec 23 '12 at 3:08

Have you tried rebuilding your Search index?

  1. Open the Control Panel - probably the best way to do this for you will be [win] + [C] to open the Charms sidebar, and then select "Settings" then "Control Panel".
  2. In the "Search Control Panel" field (top-right) type "search"
  3. Select "Indexing Options"
  4. Click the "Advanced" button
  5. In the "Index Settings" tab (first tab, default) click "Rebuild".

If that doesn't work, you can probably manually delete your index data. Note that I have not tested this, so use at your own risk:

  1. Repeat the above steps up to step 4.
  2. Under "Index location" check the index storage directory (default is "C:\ProgramData\Microsoft").
  3. Navigate to that folder and remove the "Search" folder; I would move it to a different location, not delete it outright, just in case you need to put it back.

Try those and see if either fixes your problem.

| improve this answer | |
  • Greetings Llamanerds, First of all, I appreciate your efforts. Thank you for posting an answer. However, I have stated several times withing my question that I had rebuild search index. Therefore, I ask: Have you tried reading the question and updates completely? I'm not even sure if this a copy/paste answer or not. – baturayd Dec 22 '12 at 22:51
  • Not a copy paste answer. I thought I had read the entire post, but apparently not. – Llamanerds Dec 29 '12 at 20:31

I know this thread is quite old, but I wanted to note that I just had the exact same issue (metro interface freezing only when searching) on a W8.1 system. I ended up resolving it by upgrading the Graphics Drivers.

For the posterity of those out there still chasing this trail!

| improve this answer | |
  • Can you expand upon this, such as by providing information on what graphics driver you were using and updated to? As currently written, it doesn't provide much information on the specifics of what you did. – bwDraco Aug 31 '16 at 19:49

So this thread is even older now, but I think the problem I had was similar, and I eventually tried moving my mouse to the top left corner of my screen, and a frame appeared that I could click on, and then I was able to exit the screen, using whatever icon was in the top right corner of the screen. I have no idea if this would have helped the original poster, but I'm hopeful that if anyone else searches and finds this, they'll be able to try what eventually worked for me.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.