This is continuation of Recover Extended Partition , but this time I have different problem related partition table it self.

I managed to restore partition that I needed and backed up files that were crucial to me (at least those that I had space to store somewhere)

OK now get to the problem. My partition table is corrupted, booting RIP Linux I can mount it in truecrypt (and other ones that recovered), but that's basically it. When I launch GParted I have unallocated drive.

GParted Dev info:

Device Information

Model: ATA ST2000DL003-9VT1
Size: 1.82TiB
Path: /dev/sda

Partition table: unrecognized
Heads: 255
Sectors/track: 63
Cylinders: 243201
Total Sectors: 3907029168
Sector size: 512

When I check information on unallocated space I get:

File system: unallocated
Size: 1.82TiB
First sector: 0
Last sector: 3907029167
Total sectors: 3907029168

Warning: Can't have a partition outside the disk!

Now the output of testdisc (Analyze):

TestDisk 6.13, Data Recovery Utility, November 2011
Christophe GRENIER <grenier@cgsecurity.org>

Disk /dev/sda - 2000 GB / 1863 GiB - CHS 243201 255 63
Current partition structure:
     Partition                  Start        End    Size in sectors

> 1 P Linux                13132 242 39 16353 233  8   51744768                                        
  2 E extended LBA         16807 223  1 243201 254 63 3637021626
 No partition is bootable
  5 L Linux                16807 223 57 20430  39 25   58191872
    X extended             20430  70  1 243201  78 13 3578816632
 Invalid NTFS or EXFAT boot
  6 L HPFS - NTFS          20430  71 58 243201  78 13 3578816512
 6 LNext

Now fdisk:

# fdisk -l /dev/sda

Disk /dev/sda: 2000.4 GB, 2000398934016 bytes
255 heads, 63 sectors/track, 243201 cylinders, total 3907029168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00039cd0

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1       210980864   262725631    25872384   83  Linux
/dev/sda2       270018504  3907040129  1818510813    f  W95 Ext'd (LBA)
/dev/sda5       270018560   328210431    29095936   83  Linux
/dev/sda6       328212480  3907028991  1789408256    7  HPFS/NTFS/exFAT

Now I would like to fix that to arrange partitions correctly, but I have no idea which tool is capable of fixing that (tried, a few, some of them offered fixing, but it was to risky at the moment - still backing up data).


I managed to manually edit disk entry about extended partition this allowed me to see it correctly under GParted. At this point problem is solved.


I see you are using TestDisk. it is capable of performing some partition table repairs: http://www.cgsecurity.org/wiki/TestDisk_Step_By_Step

  • This steps I actually performed and I ended up with what I have now. (Which is pretty awesome considering damage that dish have taken... First 100MB or so was overwritten)
    – dr4cul4
    Nov 9 '12 at 21:47
  • agreed. data recovery is always an iffy proposition, and sometimes you just have to be happy with what you've been able to recover. If Partition recovery is no longer an option, look into File Carving utilities like Photorec, which can recover raw data for known binary file types even when there is no working partition/filesystem remaining. Nov 9 '12 at 22:27
  • I'm in process of coping all relevant data. Whole partition is intact so there is no problem with files them selves (yeah, I lost both system partitions, but this is no problem... I want my photos - 1.1TB and source codes) I would like only to rewrite partition table correctly. I can try to do it by hand (I have done it several times in old days), but I don't have such courage now, so I'm searching for a good tool.
    – dr4cul4
    Nov 9 '12 at 23:48
  • I hate to recommend a commercial utility, but I've had good luck with this: easeus.com . source code is a real problem since it is stored as text files that have no header/footer info. if they can be recovered, the names are always gibberish. you are right, partition recovery would be much preferred. Nov 12 '12 at 6:18

I would suggest using OnTrack or any thing from the forensic data recovery market. If you are suspecting Physical damage and its a Seagate drive you can do a repair of the disk using the Sea Tools software which will let you recovery more data. Be sure to have a image backup first


I had a similar failure and just now have been able to get data off of the drive (with some bad sectors). I had to get a TTL converter, reset SMART and rebuild the partition to get the drive to do anything useful.

After that I left the terminal open and would let it run through it's errors for a few minutes.

The OS still won't read from the partition.

TestDisk worked in getting the data. I can't make an image because the drive hangs after a while, but I manually copied folders with some CRC errors here and there and recovered most of the data. I have to periodically reset the drive -- "\1", "e" from the terminal is great if you are operating remotely.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.