Booting up Windows 7 the other day, I was sent into a temporary profile. When I logged out and logged into my normal profile, all the normal icons show but with a document icon superimposed on the top.

Does anyone know any way to rectify this? I have no system restore points to go back to.

  • Cannot just delete or rename IconCache.db and reboot - it will be immediately rebuilt (broken) prior to reboot. See my answer below. – cssyphus Mar 11 '13 at 21:45

I'm adding another answer, because my new theory is that the document overlay over your icons is actually the arrow symbol, added by default to icons, that was somehow replaced by some software that you installed.

You can use the free Vista Shortcut Manager to try this theory out:

Vista Shortcut Manager is a small utility to remove/manage the arrow symbol on your icons and either remove them or replace them with some other custom graphic, you can also remove that shortcut to prefix in the text of any shortcut that windows makes.

It can be used by people looking for removing those ugly looking arrows on shortcut icons without editing registry or having to do some complex manipulation with system files and it comes in both 32-bit and 64-bit variants


  • This is definitely the right answer, but not the right solution for me. I want to keep the previous shortcut arrow, which I guess is embedded in a dll somewhere. Any idea what dll/exe/other file that is? This'll be the answer otherwise. – Tristan Warner-Smith Oct 4 '09 at 21:16
  • Vista Shortcut Manager can also be used to reestablish the overlay of your choice. I've added its screen-capture to my answer. – harrymc Oct 6 '09 at 6:08
  • 1
    Link seems to have gone south. This one worked for me, though: download.cnet.com/Vista-Shortcut-Overlay-Remover/… – Matt Ball Mar 2 '11 at 18:47

For those not wanting to install an unknown product, here are the manual steps.

NOTE THAT simply renaming the IconCache.db file and rebooting will not fix the problem under Windows7 as it will instantly be rebuilt, broken. Do this instead:

  1. taskkill /IM explorer.exe /F
  2. del %localappdata%\IconCache.db
  3. shutdown /r /f /t 00

As mbomb007 points out below, step 3 is overkill. Replace above step 3 with:

3. start explorer.exe

NOTE THAT the final instruction will reboot your computer with no prompts! But it will very likely fix your icons problem...

Source: Many places, including here

  • Thanks, I think this will help others. I'm on Windows 8 now and haven't experienced the issue there. – Tristan Warner-Smith Mar 12 '13 at 15:54
  • 1
    You don't need to reboot, you just need to start explorer.exe. – mbomb007 Oct 12 '15 at 22:36
  • @mbomb007 Good point, thank you. Answer updated. – cssyphus Oct 14 '15 at 21:04
  • Also, I find that it's helpful to first delete the file, then kill and start explorer.exe. This allows you to do it without a batch file if you prefer, since you can navigate to the file. Trying to do the steps in another order without a script is difficult if not impossible, since you can't navigate easily without explorer. – mbomb007 Oct 14 '15 at 21:11

I've never seen such a problem, so all I have to offer are guesses.
Please create a system restore point before trying out the following ideas, just in case.

First try:
Right-click on the desktop, choose Personalize, then Change desktop icons, and then click on Restore Default, then logout & login (or reboot).

Second try :
Rename the file IconCache.db located in C:\Documents and Settings\User Name\Local Settings\Application Data and reboot. It will get automatically rebuilt.

Third try:
Download the Windows 7 tweaking program Ultimate Windows Tweaker, and see if it helps you find some abnormality.

  • Unfortunately, none of these worked for me. The tweaking program didn't seem to have any options that looked relevant. – Tristan Warner-Smith Oct 4 '09 at 8:09

Follow instructions in this link :


  • +1 to counter the downvote, this is exactly the same advice as harrymc. Which didn't do the trick unfortunately. – Tristan Warner-Smith Oct 4 '09 at 8:01
  • I don't know where the harrymc answer is.This is my original post without seeing anyone's answer. – NT. Oct 4 '09 at 8:23
  • Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Canadian Luke Mar 11 '13 at 21:48

I got this from speed up pc guide site :

  1. Delete the IconCache.db in "c://user/yourusername/appdata/local/" folder
  2. Right click on space area and make a new file, name it as IconCache.db
  3. reboot your pc

For the Taskbar, a simple solution is to change icon size. Right-click the Windows Start icon on lower left corner of screen. Select Properties, then Taskbar. Uncheck "Use small icons." Icon bitmaps will be restored. However, this doesn't cure mangled icons in Explorer.


Slightly different problem & fix: This was in Win7. Suddenly a number of my desktop icons and all of my start menu icons all pointed at and if clicked would only start file X; in this case an executable file. The solution was to uninstall file X, delete the icon cache as others here suggested, reboot the machine and my icons were restored. I then reinstalled program X and have had no problems since. I don’t know if this will work, but I’m keeping a spare copy of the icon cache to try and restore it if this happens again. Never would have gotten this without the "delete the icon cache suggestion" above. Thanks to whomever figured that part out.

Not the answer you're looking for? Browse other questions tagged or ask your own question.