I'm trying to fix a computer from a friend, which has for some unknonwn reason installed the 64bit and 32bit version of CS4. The 64bit version does not work, the 32bit does.

However it seems that the 64bit version was the first installed one, associations to the .psd files are going to the 64bit version.

There seems no way to create an association with only the 32bit version. When I select open with` and I browse to the 32bit version and select open, it does not get added to the list of applications?


Unfortunately the problem just went away. It's annoying as the root cause is likely never to be found, I'm accepting Fopedush's answer for this "detailness".


I experienced a similar problem with an XP box a few months ago. After clicking "open with", then browsing to the application I wanted to use, the application still failed to show up in the "Open with" menu. The cause may not have been the same, but here is what I had to do. Warning: if you are not comfortable manually editing the registry, this solution may not be for you.

Open the registry (regedit.exe) and browse to


Find the name of the program you are trying to use, e.g.:


and browse to


The "Data" value of the default key will be the path used to launch the executable when opening a file. For example, on my machine


contains the value:

"C:\Program Files\JGsoft\EditPadLite\EditPadLite.exe" "%1".  

In my case, the path was pointing to the wrong place, and I had to manually correct it. Afterwards, the "open with" dialog worked as expected. It may be the case that the path is pointing to the 64-bit executable for you, and redirecting it to the 32-bit exe might fix the problem. Make sure to back up this key before you make any changes!

I regret that I do not have photoshop on this machine so I cannot tell you exactly what the path will be, but hopefully it is similar to the one I showed. I hope this was helpful.

  • Not only accepting, but giving +1 too. I've had the same problem again and today and your good explanation helped me solve that problem. thx – mark Apr 19 '10 at 20:15
  • +1 for excellent work. Subtle bug that nobody would ever be able to find on their own. – Ian Boyd Feb 21 '12 at 19:51

Here's a solution from another forum that I ran across as well:

I downloaded the program OpenWithView and looked at the standard entries of my open with menu. And there it was, an entry referring to the old location of the program I deleted. A simple rightclick -> disable in the OpenWith program and I could add the new program-location the normal way that has been described in this thread approx. 30 times. (right click on file -> open with -> choose program -> select exe -> voilà, program is in the menu)

Using that tool, I was able to see that the association for the program I wanted to use was pointing to the wrong directory (artifact of a bad uninstall). I then went into the registry to correct the path or the tool and now it is working.


Did you click the box saying "always open with this application"?

You may also just want to uninstall the 64 bit version then do a repair installation for the 32bit one which should fix any problems.

Or just do a repair installation to begin with and see if you can fix the 64 bit version.

If you have problems on that level, it could be that something, somewhere is corrupt and a repair installation may fix a problem that you may only find later.

  • In the dialog with the "always open with this application", the Photoshop executable, though I selected it in the browse dialog before (!), does not show up. That is my main problem here. If re-installation is inevitable, then it is. But I also would like to understand what's going on with the "open with..." issue here. – mark Oct 3 '09 at 15:33
  • If Photoshop doesn't show up in the list, then you need to browse to its executable. It's quite normal that applications are missing from the list, and more so when having 32/64-bits problems. – harrymc Oct 19 '09 at 8:34
  • As I said "... , though I selected it in the browse dialog before (!), does not show up" – mark Oct 31 '09 at 15:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.