10

I downloaded a CHM file. When I double click it it prompts me to open / save / cancel. Whether I open or save a new copy, the 'new' version will prompt the same open / save / cancel popup ad infinitum.
Searching google it seems that Microsoft have deemed it right for security reason to block these files by default. The solution is to right click the file, and click the 'unblock' button at the bottom:

enter image description here

The problem is that I don't have that button on my system:

enter image description here

BTW, the button is also missing for .exe files.
I'm using Win7 64bit. Any ideas?

5

Windows keeps the flags in an alternate data stream which is only available under NTFS.

The alternate data streams will survive copies from one NTFS folder to another, but they don't survive being moved to a FAT32 or ExFat volume. or being emailed or zipped.

So, if you don't have the rights to edit the registry or policy, you have a few options:

  1. Email the file to yourself (although some email systems will block chm files as insecure attachments)

  2. Add the file to a Zip file, and then unzip to the desired location. (Some zip utilities can preserve Alternate Data Streams, so ensure that option is switched off while zipping)

  3. Move the file to an ExFat or FAT32 volume, and then, optionally, back to NTFS if that's where you need the file to reside.

  4. Open the file in a Hex editor and then save as a new file (saving over the top of the original file may not work as some hex editors optimize the save of an unchanged file)

  5. Insert the file into an Office Document as an Object, copy the inserted object and then paste into Explorer.

  • Awesome. Zipping and unzipping fixed it for me. Thanks. – Matt Davis Jul 19 '17 at 0:45
5

The same thing happened on mine. Here's how to fix it:

  1. Open Regedit
  2. Search for the key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\HTMLHelp\1.x
    
  3. Create subkey ItssRestrictions

  4. Create DWORD MaxAllowedZone with value 2

If it still doesn't work, move the file to a different disk and reopen it to see.

https://support.microsoft.com/en-us/kb/892675

  • worked for me thx! – kofifus Jan 28 '16 at 3:16
  • Note that value = 2 may or may not be the right setting. It depends on what 'zone' the network server is in. If 2 doesn't work, I would progressively work upwards to determine what zone is needed. – DaveInCaz Nov 9 '16 at 15:28
  • Works for me, for the last suggestion of moving the file. Amazing! – eriawan Apr 3 '17 at 8:14
1

CHM files are only blockable (and thus unblockable) on NTFS filesystems. Probably all other sources of files (except network shares in the local zone) are considered unsafe.

But, the blocking was only added to XP by a sp (sp2 afaik)

  • I think your assumptions are wrong. It's not saving a file from non-NTFS volume that makes it unsafe (wat?! is NTFS magically preventing you from saving viruses or something?). It's saving file from external location that causes Windows to mark file as unsafe, but it requires support in filesystem and only NTFS supports those "insecurity" flags. Anyway, this answer doesn't solve OP's problem. – gronostaj Nov 24 '13 at 9:48
  • I mean that those "flags" are only available if you save the result on an NTFS system, since it uses forked files. Therefore, on other filesystems, the "safe" information is not preserved, which makes all files on such volume potentially unsafe since the system can not determine if they are local or files with external origin. – Marco van de Voort Nov 29 '13 at 15:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.