I am using Ubuntu 10.04 LTS. I'm looking at using git as source control for personal projects and Github as a remote repository. I was having trouble pushing a commit to my remote github repo getting the following error message:

The requested URL returned error: 403 while accessing https://github.com/Jstall/helloworld.git/info/refs

When I did some digging I found that the problem could be me not having the latest version of Git. When I did a --version I found that I have version locally. So I tried to update git using:

sudo apt-get install git

but get the following error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package git is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package git has no installation candidate

I've tried running:

sudo apt-get update

and trying again but it didn't seem to make a difference. I'm not sure if it's relevant but I'm also getting a couple of 404's when I run update:

Err http://wine.budgetdedicated.com edgy/main Packages
  404  Not Found
Fetched 4,117B in 0s (5,142B/s)
W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/edgy/universe/binary-i386/Packages.gz  404  Not Found [IP: 80]

W: Failed to fetch http://wine.budgetdedicated.com/apt/dists/edgy/main/binary-i386/Packages.gz  404  Not Found

I'm not sure when I should try next. Could anyone suggest a course of action to get this resolved? Any advice would be appreciated. Thanks much!

  • Yous should upgrade your distro. Not sure why you insist on running a 2+ year old version. – Mikhail Nov 11 '12 at 16:27
  • 2
    I don't agree that he should upgrade his distro. It depends. There are people who just need a working OS that allows surfing the web and writing a few documents. Why change something that works? This is specially true for Ubuntu Server. Ubuntu LTS is supported for 5 years. A server side upgrade is a big deal: there's a ton of testing to do once done, and everything must work perfectly. A reason to avoid unnecessary updates. But if you want to have the newest stuff and are willing to spend time learning new things, yes, update. – Abe Mar 9 '13 at 20:06

You can use my Launchpad PPA, currently it gives you git 1.8.0.

Git is available for the following Ubuntu distributions:

  • Ubuntu 12.10 (Quantal)
  • Ubuntu 12.04 (Precise)
  • Ubuntu 11.10 (Oneiric)
  • Ubuntu 11.04 (Natty)
  • Ubuntu 10.10 (Maverick)
  • Ubuntu 10.04 (Lucid)

To install my git repository follow the instructions at: Git Packages for Ubuntu • A Virtual Home

sudo add-apt-repository ppa:pdoes/ppa

To get rid of the 404, you have to remove them from your repository sources. I'm not 100% sure if I give the right instructions as I don;t have a machine with Lucid but it should fairly close.

  • Start Synaptic Package Manager
  • Settings -> Repositories
  • Other Software
  • Unselect the repositories that give you the 404.
| improve this answer | |

Apparently git on a Linux system refers to GNU Interactive Tools. The command to download the Git version control system on Ubuntu is:

sudo apt-get install git-core git-doc 

If you want or need additional tools (including GUI and Web access), you can:

sudo apt-get install gitweb git-gui gitk git-email git-svn
| improve this answer | |

This issue continues even up to and including ubuntu 16.04 ... Solution :

System Settings -> Software & Updates -> Other Software

and then checkbox ON :

Canonical Partners
Software packaged by Canonical for their partners

then issue

sudo apt-get update
sudo apt-get -y install git-core
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.