I have two laptops. One dell Vostro and other Vaio Z. Both have Synaptics (Yes, I have checked, and the original drivers were from Synaptics as well). On both laptops, the touchpad scrolling stops working at some arbitrary time and nothing seems to solve it except a reboot. Sometimes, it randomly starts working again. I have downloaded all latest drivers from OEM.

Interestingly, when I run a program as Administrator, scrolling works in that window only.

This problem is very odd. It happens without any reason and I've not been able to find a fix for more than a year. I have seen some unusual suggestions on forums (e.g., to "restore windows to a previous working state") but never any fix that solves this issue properly. I have tried installing latest drivers and I DO NOT want to restore windows to a previous working configuration.

OS: Windows 7 64 bit Professional (Sony Vaio Z - VPCZ128GG) Windows 7 32 bit Professional (Dell)

EDIT: Temporary solution is to uninstall the synaptics driver and let Windows 7 use its default built in one. However, I really prefer the Synaptic driver because it activates the scroll button rather than the mouse wheel (useful in some apps)

  • If you had the problem since day 1 why did you not try to get the benefit of warranty? – avirk Nov 11 '12 at 16:48
  • I happens nearly every time with StaxRip. Since some 3x version of Chrome this also happens when I start scrolling when the new tab is loading. The good thing is that trogper's answer works for me. – Artjom B. Aug 19 '14 at 15:48
  • Running a program as administrator fixed the issue for me, it began working again in non-admin programs! Thanks a lot! – gaborous Jan 21 '18 at 15:08

save this as .bat

taskkill -f -im syntpenh.exe
cd C:\Program Files\Synaptics\SynTP
start "" "syntpenh.exe"

that's for unfreezing TP

does the TP freeze when you do a 3-finger tap? If yes, try doing the 3-f tap few more times whether it unfreezes itself. If not, run that .bat.

  • 2
    I found a "permanent fix" for the 3 finger freeze problem! in regedit, 1) find 3FingerTapPluginID and clear that string and 2) find 3FingerTapPluginActionID and set it to 0." worked in my asus, and my friend's toshiba and acer. – arnab321 Aug 16 '14 at 9:10

I found the best way to fix it is to simply plug in a mouse, then right click on the panel on the bottom right, and choose "Hardware Settings" and then you can see the mouse pad, if its shut off and disabled you can use a mouse to re-enable it. Its the only thing that I know that works for sure. But if you are having a problem that isn't like that, I'm not too sure how else but to remove it and use windows default mouse pad driver. But before going that far just try enabling it if its disabled, and if its not, then try disabling it and re-enabling it. should work. does for me at least.


In Device Manager:-

  1. Under "MIce and other pointing devices", open "Dell Touchpad"
  2. Disable
  3. Enable

(if you don't have a touch screen, read up on using the keyboard to navigate around dialogs before trying this as it kills the touchpad completely)

  • This was the only way for me too. A definitive solution would be nice though. – jfneis Mar 12 '15 at 13:27
  • I have an Acer, and I can enable or disable the touchpad by pressing [Fn] + [F7]. When I press the key combination twice the touchpad starts to work again (for a while). – chue x Jun 10 '15 at 14:15
  • "Disable" is greyed out for me – jbaums Feb 23 '16 at 4:25
  • A way to do this via the commandline is here: superuser.com/a/560454 – luff Jun 6 '17 at 20:06

I've found that it's SynTPEnh.exe what causes it. (now I have shortcut in start to restart it) If you kill it and restart, it's working again for a while. On my PC it was freezing only with windows 8 driver with swipes from edges. I downloaded latest one from syn's site and hoped, it will be gone, but now it occurs more often.


This is my problem. For some reason the program SynTPEn stops. I solved this problem creating a .VBS file (Visual Basic Script) that reload a Synaptic program when it stops.

Create a new file named CheckSynTPEnh.vbs and save it in this directory: "C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup". By this way the script runs on windows startup.

Here is the code:

set objWMIService = GetObject ("winmgmts:")
procName = "SynTPEnh.exe"

Do While true
foundProc = False
for each Process in objWMIService.InstancesOf ("Win32_Process")
    If StrComp(Process.Name,procName,vbTextCompare) = 0 then
        foundProc = true
    End If
If foundProc = True Then
    'WScript.Echo "Found Process"
    'WScript.Echo "NOT Found Process"
    Dim objShell
    Set objShell = WScript.CreateObject( "WScript.Shell" )
    objShell.Exec("C:\\Program Files\\Synaptics\\SynTP\\SynTPEnh.exe")
    Set objShell = Nothing
End If

I hope this can help for anyone bye

  • I like how you solved the problem and at the same time wrote the basis of a virus :P – JohannesB Jan 6 '18 at 11:07

If a reboot solves the problem temporarily, then it's almost certainly not a hardware issue.

The other lead to track is drivers. Did you always had problems, or did it stop working after a software update?

Installing latest drivers does not always mean solving the problems. I would suggest installing an earlier version of the driver, or using drivers that come with the OS instead.

  • I have had this problem since day 1. From my experience, the most likely time the issue happens is when the used memory goes high or Adobe flash crashes. Flash definitely is part of the culprit. It is definitely a software issue. – Jus12 Nov 11 '12 at 15:27
  • 2
    I cannot know for sure which binaries/dependencies the drivers are using, but losing initial functionality after a while is most likely because of some binary crashing (which can be of course "corrected" by restarting Windows). – TFM Nov 11 '12 at 15:35

protected by Community Jul 30 '15 at 10:58

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.